0

I have a VPN server set up on my MacMiniColo machine running OS X 10.9.5 server.

My iPhone (running iOS 8.0.2) can connect to the VPN server via LTE.

My MacBook Pro (also running 10.9.5) can connect to the VPN server IFF if it (the MacBook Pro) is connected directly to my U-Verse modem.

So far so good.

However (here’s where it goes wonky) if I connect my MacBook Pro to the AirPort Extreme (either by Wi-Fi or Ethernet), then I can no longer connect to my VPN, and I get this message instead:

VPN Error Message

If I connect my iPhone to the Wi-Fi network created by the AirPort Extreme, then I can no longer connect either, and I get a similar message.

Google taught me that the usual problems are:

  1. AirPort Extreme has Back To My Mac enabled (but I have disabled BTMM on the AirPort and have restarted the AirPort)

  2. The IP address for the VPN is the same as the local LAN (but my VPN IP range starts at 10.0.0.150 and the local LAN uses 192.168.x.x, and I confirmed that I do get a 10.0.0.15x IP when I connect.)

  3. Port Forwarding can interfere (so I have removed all of the port forwarding settings).

I am at a loss.

I can conclude that:

  1. The username/password is correct on my iPhone and MacBook Pro, because I can get them to work, just not through the Wi-Fi.

  2. The VPN is setup correctly on the server side, because I can connect to it, just not through the AirPort Extreme.

  3. The problem would seem to be something to do with the AirPort Extreme, but I am at a loss to figure out what it could be, since I have tried everything I can to eliminate known problems with the AirPort.

So… What should I try next?

Could this be related to IPv6 somehow? I have no idea what I should use when it comes to IPv6 settings.

Update: Just to be thorough, I reset the AirPort Extreme to its default settings and tried again. I still get the same errors on the iPhone and MacBook Pro.

Update 2:

I turned on “verbose” logging and these are the only messages which appear:

Thu Oct 16 12:55:12 2014 : publish_entry SCDSet() failed: Success!
Thu Oct 16 12:55:12 2014 : publish_entry SCDSet() failed: Success!
Thu Oct 16 12:55:12 2014 : L2TP connecting to server 'my.servername.here' (my.server.ip.here)...
Thu Oct 16 12:55:12 2014 : IPSec connection started
Thu Oct 16 12:55:12 2014 : IPSec phase 1 client started
Thu Oct 16 12:55:22 2014 : IPSec connection failed
  • Is the Airport set to Bridge mode under the network tab of the Extreme configuration? – rchrdg Oct 15 '14 at 12:12
  • No, the AirPort is also the DHCP server for the network. – TJ Luoma Oct 16 '14 at 13:09
  • Have you configured the DMZ on the Uverse modem to allow VPN traffic through its firewall? If I recall Uverse does not like it when you use 10.0.0.x ranges internally as well but that may be specific to certain modems. – rchrdg Oct 16 '14 at 20:03

You must log in to answer this question.

Browse other questions tagged .