2

I have been trying to use the Java Decompiler, JD-GUI, on my 2007 iMac running OS X 10.9.5 for the past week, but I have been running into a road block.

Disk image corrupted?

Only a few weeks ago, I did not have this problem. What I've normally done is have the disk image in my Downloads directory, and I open the disk image and used the application from the image directly. However, one day, I received that error for the first time, so I went and redownloaded it from the provider of the software, but kept running into the same issue.

I have tried this from multiple Internet connections to no avail.

Also worth noting I think is that when I drag the application from the disk image, its file size is only 2KB, which is a problem. Upon opening the application then, it says the application is corrupt and it moves it to the trash.

Is there any fix or workaround for using this software? I'm trying to understand why it was working only a few short months ago.

JD-GUI can be found here: http://jd.benow.ca/

Edit: Worth noting is that the checksum values match for both the downloaded copy and the one listed on the download page! Perhaps an issue with 32-bit vs 64-bit libraries?

  • Have you updated anything (Java, OS X) lately? – 0942v8653 Oct 14 '14 at 1:30
  • @0942v8653 Not that I can remember. Maybe 10.9.4 to 10.9.5 a few months ago. Checking my Java version, it also seems like not much as happened there either. Typing java -version into Terminal gave me java version "1.7.0_25". – Justin W. Flory Oct 14 '14 at 21:00
2

Apple's OSX Mavericks 10.9.5 update changed some app signing rules. I'm not sure if that's exactly what's happening with JD-GUI, but it seems plausible.

To bypass the Gatekeeper check that's popping up the error, launch the app directly from a Terminal prompt:

$ /Applications/JD-GUI.app/Contents/MacOS/jd-gui &
  • By jove, it works! I'm totally surprised by this. Thanks for sharing this tip! Go figure they change something to block it from working. Do you have any idea how to make it work automatically so I don't have to launch it via command line? For the record, this is my console output whenever I run the command. – Justin W. Flory Oct 30 '14 at 22:46
  • This might open a wormhole... if you put that line in a bash script, then run appify on it - you get an app that runs your script that launches your app. – rymo Oct 31 '14 at 15:35
  • Wonder what would happen if I reinstalled Flip4Mac? – Justin W. Flory Nov 1 '14 at 18:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .