0

I was trying to repair a corrupted partition (OSX Mavericks) the mac doesn't boot anymore (grey apple logo with infinty spinning gear). I've just tried with safe mode, PRAM restor etc... And the recovery HD partition doesn't boot the UD so I had to create a bootable USB mavericks installation and start there the UD.

When i run, from terminal: diskutil repairVolume /dev/disk0s2 it return an error of bad ref of that file system with this code -69846. after that i can't see anymore the disk0 through diskutil list. also, I cannot erase the partition because it appears unmounted (light grey text on the HD list)

I've tried also to start an install of mavericks directly but it doesn't show me the SSD to locate the installation.

What can I do to fix this problem?

1

If you have booted from other media and tried Apple's tools then the only thing(s) left are 3rd party tools.

My go-to is Diskwarrior and while some drives with a lot of files will cause it to fail (so I have heard) I've, personally, never had an issue with it. It has always worked and almost always fixed the problem.

Failing that TechTool pro and Prosoft Engineering are a couple of other places to look.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .