15

I am experiencing a problem with updating my apps on all of my Apple devices: iPhone 5s, iPad Air, iPhone 4s, iPad 3

They are all running iOS 7.0.4 (11B55a) jailbroken using evasi0n and this problem has only recently started happening.

To update my apps I normally go into the "App Store" app down to "Updates" and then manually press the "UPDATE" button to update that app. Since the 10th October pressing the "UPDATE" button causes the app to be loaded instead. I went to try this on my other devices and got exactly the same result. This is odd because some of the devices haven't had any Cydia or App Store updates for ages.

I have attached a screenshot of what my update screen looks like on my iPhone 5s:

You will notice that:

  • Update All is greyed out although it does start off blue for a split second before going grey.
  • Apps updated on the 8th October correctly show the "OPEN" button.
  • Apps updated on the 10th October incorrectly show the "UPDATE" button.

I have tried the following, but none of these have worked:

  • Turning off WIFI to use 4G instead.
  • Restarting the iPhone 5s.
  • Signing out and logging back into my Apple account on the iPhone 5s.
  • Syncing the iPhone 5s with iTunes on my Windows PC.

I have tried the following which does work, but doesn't make any sense:

  • Pressing on the app icon to expand the description and again to load up details of the app. The "UPDATE" button on the app detail page works for some reason, but strangely keeps prompting me to put in my password for my account.
  • When loading up "App Store" and pressing in the top right "Update All" quickly before it is greyed out actually starts the update of all apps.

In summary there are 2 problems that are happening:

  • Trying to update an app from the main update screen loads the app.
  • Apps that have been updated show the wrong text for the button "UPDATE" instead of "OPEN".

Does anyone have any suggestions as to why this is happening now? I have previously been updating fine before the 10th October.

Seems like I am not the only one experiencing this problem:

  • 1
    You've tried force-quitting the App Store, restarting your phone, then reopened the App Store? – user11633 Oct 14 '14 at 19:59
  • Yes I tried that, it made no difference. I am sure it is something that Apple has changed on the backend. – Grant Rogers Oct 16 '14 at 7:52
  • 1
    Hate to say it... But... "Me too!!!" My guess is this is apple kicking iOS 7 users into their stupidest update yet (iOS 8)... But I digress. – HelpingHand Oct 17 '14 at 18:40
  • You have tried to hard shutdown your iPhone using Power and Home button ? smallbusiness.chron.com/hard-shutdown-iphone-67721.html – StrawHara Oct 19 '14 at 6:38
  • @MrMojoRisin, yes I have, no change. – Grant Rogers Oct 20 '14 at 20:16
1
  1. Go to Settings -> iTunes & App Store -> AppleID -> Sign out.

  2. Close the App Store app (double-click home button, swipe up on App Store), and restart the phone -- but instead of holding the power button and shutting down "cleanly", hold the power and home buttons until it powers off. Power it back on.

  3. Settings -> iTunes & App Store -> Sign In. See if you get the same results.

If that doesn't do it, try deleting the affected apps, then shutting the phone off cleanly, then starting it back up and re-installing the apps.

  • Thanks for the suggestion, but I have tried that before and it makes no difference. If I were to delete all the affected apps, that would be all of them ;). This really is a combination of the version I am on and something that Apple has done at the back end. Apparently this is fixed with version 7.1 up, but I do not think I can upgrade to that version and keep my jailbreak now as Apple have probably stopped digitally signing that version. I will probably have to wait until iOS 8 jailbreak before I get this fixed. – Grant Rogers Oct 20 '14 at 20:15
  • Ah - I didn't read your question carefully .. the jailbreak throws a real wildcard into this. – Harv Oct 20 '14 at 20:21
  • @Harv I have the problem too but I never jailbroke this iPhone (have done it with others. I've pulled out enough of my hair) – HelpingHand Oct 29 '14 at 23:07
  • @Harv BTW, I only got this problem after they released IOS 8. I'm on 7.0.4 right now (no intention of updating). – HelpingHand Oct 29 '14 at 23:10
0

Do you maybe have an app listed there, that you installed via another method such as AppCake (Found in Cydia/Is a utility that installs free and paid apps for free, on Jailbroken iDevices)? If so, that may be the problem, and there's a setting in AppCake to remove the metadata of the app, so it doesn't show up in the App Store like it currently may be (You Can't update apps you did not actually purchase on the App Store, via the App Store)...

If you installed via another method, aside from AppCake, there are ways to remove the metadata from the App's installer file (.ipa file), before you install it.

If this is the case in your situation, remove/delete the app, then reinstall it with the metadata removed, and then, try your updates again to see if the issue is resolved.

Hope this helps :)

  • Hi @jtrag, I am afraid I cannot test this anymore as I have upgraded all my IOS devies to 8.1 using Pangu (although I believe this is no longer possible as 8.1.1 has come). Upgrading has fixed my problem as I am now successfully able to update with the same applications I had before. – Grant Rogers Nov 30 '14 at 0:51
  • Excellent. Glad to hear it's sorted out now, one way or another :) – jtrag Dec 13 '14 at 6:15
0

For me on IPad 2 upgrading to the latest iOS version fixed the issue

You must log in to answer this question.

protected by Community Oct 12 '14 at 16:44

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .