1

I'm on mavericks and I am trying to delete a partition of an external hard drive. This is its schema

Partition1: 50GB  "MavericksBackup": Bootable backup
Partition2: 187GB "Home Data": Absolutely Empty
Partition3: 12GB  "Install OS X Mavericks": it contains only the bootable app to install Mavericks

Now I'm trying to Erase the Partition3 from Disk Utility and it fails with the following error:

The requested size change for the target disk or a related disk is too 
small. Please try a different disk or partition, or make a larger change.

What that even means?

I have tried to delete or resize also the Partiton2 and I get the same error. I suspect the problem was created by Carbon Copy Cleaner: I've used it to copy everything from my internal HD to Partition1 to make it bootable. At the beginning of the process a warning message told me that in order to make Partition1 bootable I also had to create a recovery partition. I let it handle it.

Now, in fact I don't see the Recovery HD partition from disk utility but if I launch diskutil list I do get this (different) list of partition, including the Recovery one, not visible from Disk Utility:

/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  GUID_partition_scheme            *250.1 GB   disk1
   1:                        EFI EFI                     209.7 MB   disk1s1
   2:                  Apple_HFS MvaricksBackup          49.9 GB    disk1s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk1s3
   4:                  Apple_HFS Home Data               187.3 GB   disk1s4
   5:                  Apple_HFS Install OS X Mavericks  11.6 GB    disk1s5

Not sure how to solve this? I would really avoid to reformat the whole disk...

EDIT: I started the disk utility in debug mode with this terminal command defaults write com.apple.DiskUtility DUDebugMenuEnabled 1 then Debug menu and Show Every Partition. This in fact shows the extra EFI and Recovery HD partition but that didn't help me solving the problem.

5

I did fix this by resizing (making it a bit smaller) the Partition1.
After doing this I was able to delete/resize all the other partitions.

Well, I have no idea why this happened, so this is not a real solution but probably a bug of diskutil.

  • Leonardo, which partition exactly did you shrink? Which is Partiton1? And how did you do it and by how much? – user101599 Nov 20 '14 at 11:08
  • I think the answer is pretty detailed as well the table of partitions. I did it with disk utility (the topic of this question) and as I remember I made it more or less a hundreds of MB smaller. Please read the full question before answering or commenting and look the introduction tour – Leonardo Nov 20 '14 at 11:17
  • 1
    Did you use Carbon Copy Cloner to clone to the drive and create the recovery partition on it? I did and had the exact same problem and solution. I have asked Bombich Software why when you use their software to create the recovery partition, any partition after it can not be removed without the too small error. – Allan Nov 20 '14 at 20:25
  • yes I did use CCC – Leonardo Nov 21 '14 at 12:07
2

I have found that using Recovery Partition Creator 3.8 works for me. I use Carbon Copy Cloner to clone the other partitions but Recovery Partition Creator for the Recovery HD partition. It appears to handle the issue of removing partitions after the Recovery HD partition properly, and also works if you have left free space after the volume that the Recovery HD partition is created from.

I haven't done exhaustive testing, but so far so good.

http://musings.silvertooth.us/2014/07/recovery-partition-creator-3-8/

You must log in to answer this question.

protected by Community Nov 21 '14 at 10:29

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .