7

Is there any way to enable flash video hardware acceleration in Google Chrome? I get up to 300% cpu usage, while playing flash video.

Using OSX 10.9.5 and latest Chrome on a MBPr 13" late 2013.

In Safari I get around 90% CPU usage. Which is bad, but not as bad.

9

Step 1 would be to look the status of your Chrome GPU settings.

Paste this "chrome://gpu/" in Chrome web address field.

On my MBA 10.9.5 Chrome Version 38.0.2125.101 it looks like this

Graphics Feature Status
Canvas: Hardware accelerated
Flash: Hardware accelerated
Flash Stage3D: Hardware accelerated
Flash Stage3D Baseline profile: Hardware accelerated
Compositing: Hardware accelerated
Rasterization: Software only, hardware acceleration unavailable
Threaded Rasterization: Disabled
Video Decode: Software only, hardware acceleration unavailable
Video Encode: Hardware accelerated
WebGL: Hardware accelerated
  • Pending on your result (Flash- Not accelerated) proceed to step 2:

Do following:

To force Chrome / Chromium to use hardware acceleration, open a new tab, type "chrome://flags" (without quotes), search for "Override software rendering list", enable it and restart Chrome / Chromium.

  • Optional Step 3 (my settings)

Paste this "chrome://plugins/" in web address field.

Disable the Chrome build in Adobe Flash player aka PepperFlashPlayer.plugin

If you have not already have done so, get the Adobe Flash player from Adobe, that will be now used by Chrome.

  • Hardware acceleration was enabled and I had Adobe's Flash plugin installed, but Pepper was not disabled. Disabling it and reloading the page got me half the cpu usage. Thanks! – Znarkus Oct 13 '14 at 6:58
0

Thanks for sharing. It works for me with some additional adjustment.

All my flash videos on facebook stopped working. Black/ Green screen no video but with audio. Couldn't disable Flash settings hardware acceleration. Some how the flash menu hung after opening it up.

So this is the only workaround for me. From chrome://flags I disable "Disable hardware-accelerated video decode" and relaunch my Chrome browser. Now all Flash videos plays fine. I'm a happy person once more. :)

-1

This command allows me to stream content without running out of memory:

Google-chrome --disable-gpu 

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .