I've got a 27" dual-core iMac of the generation before the current one. HDD is 2 TB, RAM is 8 GB. I've got Aperture 3 installed and updated, with a photo library totaling 180 GB.

With increasing frequency, Aperture fails to launch. The icon bounces for a while in the dock (maybe about 30 seconds) and then stops. I have iStat Menus installed, and I see no real change in system activity while the icon is bouncing. If I open Activity Monitor, I see the Aperture process listed, and I have to force quit it. Once this happens, whether I force quit Aperture while it's bouncing or afterwards from Activity Monitor, things just don't behave; other applications fail to launch in the same way. If I try to restart after failing to launch Aperture, I get a blue screen with an activity indicator that never goes away.

I've also had iTunes freeze, and it will often lock up the whole operating system, so that absolutely nothing responds besides moving the mouse. This requires a hard restart to resolve. It's a moderately sizeable iTunes library that serves as the source for media played on an AppleTV (latest generation) elsewhere in the house.

I also recently imported a lot of new footage into iMovie '09, and Spotlight has been continuously indexing since. That was several days ago, and I see nothing in iStat Menus to indicate that the index process is doing anything; the Hard Drive IO section is as active as it is when the computer is idle. The last time I tried to update my Time Machine backup, it spent several hours in the "Calculating Changes" status before I stopped it.

I've tried repairing the Aperture database and repairing permissions and the Macintosh HD, to no avail. My best guess is that something is wrong with the directory structure, and I'm going to have to back everything up and reinstall the OS from scratch. But is there a simpler solution? Anyone have any ideas? Any utilities I can use that are more advanced than Disk Utility at finding HDD issues, physical or not?

UPDATE 6/3/2011: I ran DiskWarrior's file and folder utility on my drive last night, and it found that iPhoto's mosaic plist was corrupt. I moved it out of ~/Library/Preferences to my desktop and pulled up System Preferences, hoping to get the Mosaic screensaver working. After I selected the Desktop and Screen Saver pref pane, the whole system locked up and I had to force restart. I also tried renaming my Aperture library and launching Aperture to see if it was a library problem, and it still bounced forever and then stopped, while still appearing as a process in Activity Monitor. And I noticed while renaming the library that its size showed up as about 600 MB, when I know it's supposed to be over 180 GB. I'm going to boot into DiskWarrior and run its directory repair, then reinstall Aperture and hope for the best.

  • What's in the console app for those applications? There might be something there that could point to the trouble. Commented May 31, 2011 at 4:12
  • I've looked, and don't see anything notable. When I force quit Aperture, it just says the process was killed. Commented May 31, 2011 at 15:27
  • I'm assuming the answer is yes, but I'll ask anyway: are aperture and iTunes both up-to-date? Is the OS also up-to-date? Another option might be to simply reinstall Aperture and iTunes to see if that would work, that way you might avoid the reinstall of the entire OS. For spotlight, I suggest telling it not to index the movie directory to see if it helps. Annoying if it does, since searching won't work there, but I've had to do the same thing to my Virtual Machine folders since big files w/ lots of changes seems to nuke Spotlight. Commented May 31, 2011 at 20:47
  • Yes, everything is up to date. Commented May 31, 2011 at 23:24

2 Answers 2


Since more than one application is having issues, it's unlikely to be two bugs and more likely to be a system or hardware issue.

Before spending a lot of time, make a new user and see if that user has issues as well. You could have bad luck and lots of corruption in your user folder and this will let you know if the problem is with the apps/system/hardware or not.

Drive Genius might help to run more involved tests, but it might be cheaper to just buy a spare external drive and back things up. You can zero the drive and clear all bad blocks - give that hardware the best chance to work again. You will know soon after restoring your data on the newly erased and installed mac if the problem is resolved.

Good Luck!


This ended up being solved by the nuclear option: backing up, wiping it clean and reinstalling everything. I did that in order to install Lion. Now everything works great.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .