7

i have a Bose Soundlink Mini connected to a Macbook Air. When the Soundlink turns off after a time (because of energy saver mode), iTunes automatically starts playing music. I didn't find any option to disable that, nor any information about others with the same problem. Do you have any idea, why this happens and how i can solve it?

5
  • Could you check what you have in the /Library/iTunes/iTunes Plug-ins/
    – Ruskes
    Nov 24, 2014 at 19:16
  • Dunno about OP but I have Quartz Composer Visualizer.bundle. This is happening on the disconnect w/ Bose Soundlink though so I dunno how much iTunes plugins are related to the problem.
    – Opt
    Nov 26, 2014 at 21:54
  • Same for me here, Quartz Composer Visualizer.bundle only.
    – dunni
    Nov 27, 2014 at 5:34
  • Same problem here
    – k1r8r0wn
    Apr 3, 2015 at 2:39
  • I have the same problem when I disconnect the EarBud from MB Air Mid 2012. It happens pretty much with every other device too. I’ve learnt to live with it, but a solution would be nice. I think it’s because iTunes used to have feature where it would stop playing music when a device was disconnected from the port, but some how it got inverted; to start playing
    – user14492
    Apr 29, 2015 at 23:01

1 Answer 1

1

This (http://forums.macrumors.com/threads/how-to-stop-itunes-from-opening-with-bluetooth-speakers.1666895/) worked for me --

In Finder go to Applications and show package contents on iTunes.app. Inside the MacOS folder there is a unix script called iTunes, I renamed it iTunesclosed. Also renamed ituneshelper.app to ituneshelpdisabled.app

Remove the iTunesHelper.app from starting on login via System Preferences -> Users and Groups

Also kill the iTunesHelper process via Activity Monitor.

Edit: Note that you may have to do this every time iTunes is updated.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .