1

I run Windows 7 almost exclusively at this point. I use a logitech windows bluetooth keyboard while at home. Running Freebsd through VMware Player, I installed emacs and have had to resort to using Esc instead of Meta. I have tried the following combinations without success:

Logitech keyboard: Ctrl, Alt, Windows

Macbook keyboard: fn, control, option, shift-option (alt), command

I know that Esc works, but it does not seem to allow successive presses of the modifying key without releasing Esc and pressing again. I am not sure whether this issue is a bootcamp issue, or a host-client issue with the VM or some combination of the two. Has anyone run into this before? I realize it could be very specific to my setup, but am hoping someone can help.

1

I will presume that you're using emacs in the console on FreeBSD inside VMWare on Windows 7 running on a MacBook.

Try using a system-provided keymap designed for emacs.

kbdcontrol -l /usr/share/syscons/keymaps/us.emacs.kbd

If that doesn't work (or if that file doesn't exist), you can try making a custom keymap. See the emacs wiki page about the meta key for more information.

Meanwhile, that page might help you even if you're running emacs under X, rather than in the console.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .