2

I thought I disabled cellular usage for several games in the past. Going through the list of which applications I've allowed to use cellular data, I noticed there are a few still enabled. I flip them off and go on with my day. However, I've noticed that there are some applications which keep getting re-enabled!

On iOS 7.1.2 on an iPhone 4S, I am able to reproduce this:

  1. Go into Settings/Cellular.
  2. Disable cellular usage for Angry Birds.
  3. Go back to main settings screen.
  4. Go back to cellular settings.
  5. Angry Birds is still cellular data enabled!

There is no error message, no indication that it didn't succeed. I've even tried rebooting the phone to see if there was some other error. Nope, this app plus several others refuse to keep their "disabled cellular data" setting. I have free RAM and free storage, so I don't think it should be a matter of available resources to complete the operation.

It is worth noting that there are numerous other applications on my phone that allow me to flip/flop their setting with no problems. Some other applications that are preventing me from doing this (if it is an app thing) are Hill Climb, KidsDoodle, Monster Dash, PunchQuest and PvZ.

Has anyone else seen this? Any reason for it? How can I fix this?

I am not considering upgrading to iOS 8 at this time given the unresolved issues and performance impact on a 4S.

thanks!

1

I had the same problem and the above fixes didn't help either. What ended up working was turning off the apps I wanted off, and then turning off cellular data altogether. Then moved back out of Cellular to the main Settings menu, then back to Cellular and my apps were still off. Then switched cellular data back on and the apps I wanted off stayed off. I also tried deleting and re-adding the offending apps and that worked too.

  • Hmm... That didn't work for me. :/ When I disabled cellular data alltogether, the offending apps enabled themselves again, even before leaving the menu. – Hjulle Sep 5 '15 at 18:21
0

Try to close the app completely, by the multitasking-bar and to disable the cellular after that. Maybe the switch won't work, if the app is still running.

  • It isn't that... I haven't run some of the applications listed (including Angry Birds which was the guinea pig for the test) in quite some time. – bjb Oct 10 '14 at 14:46
0

In case anybody is looking for an answer like I was, here's another one. I've been looking for months. Someone had told me that the app has to be running in order for the change to stick. So, being desperate, I tried that. Turns out (FOR ME), I got a message saying that cellular data was turned off for the app. I went back to check if it really was, and according to my settings it was still on. So the actual app registered the request, but the cellular settings didn't. Basically, turn it off, and even when it says it's still on, try to reopen the app.

0

I also had this problem for several months. When I upgraded from iOS 7 to 8 it resolved itself. I think the culprit must have been some corrupt preference files, cache or similar.

-1

Go to the list of apps under settings. When you select it you can turn off cellular service within the app. Then turn it off under cellular.

  • As per the question description, this is what I was doing; the setting simply doesn't work for the identified set of apps. – bjb Oct 14 '14 at 16:50

You must log in to answer this question.

protected by Community Mar 19 '15 at 12:31

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .