5

I've been using my external HDD a lot of times before on my Macbook Pro 13" OS X version 10.9.5, but it doesn't seem to appear in my Finder anymore. It can be seen in Disk Utility, though. Can anyone help?

I've already checked the Finder > Preferences > ... And, I've already run Repair Disk and clicked on Mount, to no avail. I don't want to reformat the disk because it has years of files and pictures.

This is the info on my external HDD:

Name :  HW Drive
Type :  Partition

Disk Identifier :   disk1s1
Mount Point :   Not mounted
File System :   Windows NT Filesystem (Tuxera NTFS)
Connection Bus :    USB
Device Tree :   IODeviceTree:/PCI0@0/EHC2@1A,7
Writable :  Yes
Capacity :  320.07 GB (320,071,884,800 Bytes)
Owners Enabled :    No
Can Turn Owners Off :   No
Can Be Formatted :  Yes
Bootable :  No
Supports Journaling :   No
Journaled :     No
Disk Number :   1
Partition Number :  1
3
  • 2
    The info says “Not mounted”, which explains why it doesn't show up in the Finder. So the question is why it didn't get mounted why you clicked “Mount”. It seems strange that it would fail without Disk Utility showing an error message. You could check whether its log (accessible from the Window menu in Disk Utility) has additional information. Otherwise you may need to ask the developer of Tuxera NTFS why the mounting action might “silently” fail.
    – Rinzwind
    Oct 10 '14 at 10:27
  • Maybe the drive failed? Have you run any hardware tests on it? I recommend SMART Utility(it will need SAT SMART driver installed to support external drives, if yours is supported.)
    – Fyrefly
    Oct 10 '14 at 18:25
  • I had the same problem. Mount said the disk needed to be repaired, repair said it was dead and to retrieve anything if it was visible (which it wasn't) and format the drive. I tried this a few times on 2 different macs - then on the last try I clicked 'Eject' from inside Disk Utility and then unplugged/plugged it back in and it worked. I wouldnt have thought this would have made a difference - but it worked once so as a last stitch effort it may be useful to anyone else who found themselves here via google.
    – Jonny
    May 9 '15 at 3:41
6

This fixed mine:

In Finder:
Finder>Preferences>Sidebar>DEVICES>
Then I unchecked and re-checked (deselected and then reselected) "Hard Disks" and they came back. (even though they were external) Basically try unchecking and checking them all.

I'm also now running disk checks.

2
  • This one worked like a charm for me Nov 19 '19 at 12:37
  • Bizarre, thanks.
    – Anthony
    Mar 9 at 9:06
2

As I said in a comment above, it seems the “Mount” action silently failed. I assume from the mention of “Tuxera NTFS” in the info on your HDD that you are using that software to get read/write support for NTFS volumes (OS X only offers read support out-of-the-box). The Tuxera NTFS FAQ says:

The most common reason why Tuxera NTFS for Mac doesn’t mount an NTFS volume is that it contains errors or inconsistencies. [...]

To recover from this situation, attach the drive to a Windows computer and run ‘chkdsk /f’ on the drive to repair any problems in its internal structures. See http://support.microsoft.com/kb/315265 for usage information regarding ‘chkdsk’.

3
  • Strangely enough, when I ran it on Windows, the disk seems perfectly fine!
    – Heini
    Oct 13 '14 at 3:00
  • But it still doesn’t work on the Mac? I’m not sure what else to suggest then other than that you could try to temporarily uninstall Tuxera NTFS (or try on another Mac) and check whether OS X’s out-of-the-box NTFS support does allow mounting the drive, or contact the Tuxera development team for more information.
    – Rinzwind
    Oct 13 '14 at 9:15
  • @Heini Did you checked it with chkdsk as Rinzwind suggested? Mac is not best tool to repair Windows filesystem. It is better to do it from Windows. Check it with Fix flag and post log here
    – iskra
    Dec 24 '14 at 22:37
2

If the hard drive is showing up in Disk Utilities:

  • In Finder click on Go To —> Go To Folder and enter /Volumes
  • If your external drive is showing up there drag it to the devices-section in the Finder-sidebar where your other devices (e.g. CD/DVD-drive are)
  • You may need to tick external harddrives in Finder settings —> Sidebar before
2

Do a Search on Mac (Command + Space Bar), Type in "Paragon" it should load:

  • Paragon NTFS for Mac OSX
  • Click it, the bottom of that should say "System Preferences"
  • Double Click that, it should lead you to its setting
  • Check the "Turn the Paragon NTFS for Mac OSX Driver off"
  • Unplug your USB from the MAC
  • Plug your USB back into the MAC
1

I had the exact same problem on my Macbook Pro 15" OS 10.12.

Finally what worked was right clicking the volume as it displayed in Disk Utility and select "View in Finder" from the drop down menu.

screenshot of HD in finder browser

Up popped a Finder window and I could view all the HD and contents. Unfortunately the external drive still doesn't appear in the favorites list on the left, but at least I can launch a Finder window for the external now.

0

My bro did some clicking after that he says the Seagate 1 TB Backup Plus external hard drive was showing up in finder and desktop on his MacBook Pro. He did say it could be due some software corruption because he clicked something and probably something got installed. He doubted the Seagate dashboard.

Below are the troubleshooting steps that resolved the issue:

  1. Checked the same external seagate 1TB on another mac thin air system and the harddrive was working fine.

  2. Checked a different seagate external hard drive on the Mac pro notebook and the external drive is not showing up in the finder or on desktop.

  3. Checked in Finder preferences>>General>>and ensured that "external disks" is checked under (show these items on the desktop.

  4. Checked the disk utility on the MacBook Pro and the external drive is detected however it is not mounted.

  5. as per customer input suspected could be some hard drive application that is causing, removed the seagate dashboard application however, still same.

  6. Then checked for other unknown application related to hard drive. Found "Paragon NTFS" in the system preferences (my external hard drives are formatted with ntfs).

  7. Uninstalled the third party Paragon NTFS application(Possibly supplied with the Seagate Dashboard Software).

  8. Restarted my computer.

Voila!! My external hard drives are back in finder and desktop.

0

The only thing that worked for me was

  1. connect the hard drive to a Windows computer. Then just plug it in your Mac, no problem.

  2. turn off and on Spotlight through the Terminal. This works 100% as well.

0

My scenario is a bit different. MacOS High Sierra, 10.13.3 running on a late 2014 21.5" iMac. I have an external USB SATA dock with 4 slots, each of which is filled with a 3.5" drive. One of the drives was not showing as mounted in Finder (I spotted this due to TimeMachine not finding the disk for several days), but the drive showed as mounted in Disk Utility. I ran First Aid in Disk Utility for the errant drive, then checked Finder. Nope. Disk Utility says it's mounted. Relaunched Finder from Force Quit, and now the volume is mounted.

-1

Okay, under Finder>Preferences>Sidebar>DEVICES>"Whatever the name of your Mac may be" Click that box to show in finder. Now click on it from Finder, again it'll be under devices and it'll be whatever you named your Mac(Mine is, "Kevin's Macbook Pro". Now you should see your External Drive like usual!

1
  • OP said he'd already checked Finder prefs. & the drive is clearly not mounted Mount Point : Not mounted
    – Tetsujin
    Oct 21 '15 at 5:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .