5

Starting up iTunes on my Windows 8.1 computer to sync iPhone 4 via USB immediately brings up the error message:

The iPhone can't be synced. An unknown error occurred (-54)

Any ideas how to overcome the error?

6

Error -54 is a file permissions issue.
Here are a couple of methods to reset common errors...

Fix the iTunes folder permissions

Open the Start menu & type %userprofile% (including both % symbols) then hit Enter you should see the My Music folder, which is the default location for iTunes music files.

Open My Music, select the iTunes folder

Then, make sure you have sufficient control over the contents of that folder -

  • right-click on the folder, go to Properties
  • Security tab, Advanced..
  • Permissions tab, Change Permissions...
  • click your account name in the list, make sure it says 'Full Control' [if not, reply to that effect & we will need to revise this answer]
  • check the box underneath for "Replace all child object permissions with inheritable permissions from this object"
  • click OK. That should recursively give correct permissions right down the folder hierarchy.

Try your sync again…


Additional method, if the first doesn't work…

Restore TrustedInstaller permissions

  1. Right click on the file or directory.
  2. Click on “Properties” on the right click menu.
  3. Click on “Security” tab.
  4. Click on “Advanced” button at the bottom.
  5. In Advanced Security Dialog window, click on “Owner” tab.
  6. Here you will be able to see current owner (i.e. Trusted Installer).
  7. To take ownership of the object, click on the Edit button. Give permission to UAC. Then highlight the user name in the “Change owner to” box that you want to assign as the owner for the object. Click “OK” to finish the process.
  8. Back in Advanced Security Settings window, you will see the current owner has changed to the user you just selected.
  9. Click “OK” button to exit this window.
  10. Click “OK” again to exit completely from the Properties window.
  11. Repeat step 1 to 4 to open the object’s Properties window again.
  12. Back in object’s Properties window, click on Edit button, and confirm the UAC elevation request.
  13. Highlight the Administrators in the “Group or user names” box. If the user ID or group that you want to manage the permissions for the object doesn’t exist, click on “Add” button, and type in the user name or group name desired into the “Enter object names to select (Can use Everyone as user Name)” box, and finish off by clicking on “OK”.
  14. In the Permissions for Administrators box below (or any other user name or group name you chose), click on “Full Control” under the “Allow” column to assign full access rights control permissions to Administrators group. Also refer this link http://windows.microsoft.com/en-us/windows-vista/Troubleshoot-access-denied-when-opening-files-or-folders

Update June 2016
Apparently, the layout of the perms windows has changed in Win 8 & later - see
Set Folder Permissions in Windows 8 or 8.1 Computer or
How to Take Full Ownership of Files & Folders in Windows 8 / 10 for further info.

If neither of the above methods works...

There is a utility called Windows Repair (All-in-One) by tweaking.com which I would highly recommend for a non-expert way to ensure Windows has all its correct defaults.

It is not any kind of "go-faster" tool, it doesn't speed up your machine in some 'magical' way. It just makes sure everything is as it should be. It won't break anything, so long as you follow the instructions precisely.

The free version is all you need, though personally I bought the pro version just to reward the author. [I have no affiliation, it's just saved my neck enough times to be worth recommending]

  • Brilliant. How did you figure this one out? I am wondering how/ why the privileges would even change in the ACLs, esp when it was working a month or so back? – Alex S Oct 16 '15 at 10:22
  • 1
    I'm not really sure how it could occur in the first place, but perms/Trusted Installer seems to crop up in many Windows issues, so that is just my first port of call for anything that looks like a perms issue. I'd just call it a 'standard toolkit' fix. If you really want to check your entire machine through for 'correct defaults' then tweaking.com's All in One is a great tool, & won't break anything, so long as you follow the instructions precisely. – Tetsujin Oct 16 '15 at 10:35
  • I only used the first half method 1 that you mentioned and also ran iTunes as Admin. I am saving this - Thanks a lot. I know about permissions errors but did not realize they would show in such ways without any changes in a month. – Alex S Oct 16 '15 at 10:37
  • 1
    Ah - they changed the name recently, though it's still the same thing - now called 'Windows Repair'. The free version is all you need, though personally I bought it just to reward the author. [I have no affiliation, it's just saved my neck enough times to be worth recommending] – Tetsujin Oct 16 '15 at 10:38
  • Can you please update the instructions a bit for Win 8.1, Especially Method 2, as I cant seem to open "Owner" tab - there is a link for it but no tab. If you want I can share a screenshot for you. – Alex S Oct 30 '15 at 9:01
0

I ran into this problem with permissions on my daughter's phone. Restrictions was enabled and that made this error when trying to sync.

  • 1
    Settings->General->Restrictions – Scooter Sep 18 '16 at 4:08
0

Much appreciate your efforts to help, but as noted in many posts, Windows 10 goes through the motions of changing the file 'read-only' attribute but refuses to actually do so.

In my case, the sync errors only occurred when I had my contact manager (MS Outlook) running, so it was locking the files.

Exit Outlook, run iTunes to do the sync, and problem solved.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .