1

I removed the EFI partition accidentally but I have it on a Time machine backup. Is there a way to simply move it from my external drive to my boot drive.

enter image description here

I've tried restoring the format of the boot drive EFI but it gives me an error.

bash-3.2# diskutil eraseVolume fat32 EFI disk0s1 Started erase on disk0s1 Unmounting disk Error: -5344: MediaKit reports not enough space on device for requested operation

Any help will be awesomely appreciated.

5
  • So we learn how did you mange to erase it,could you tell us.
    – Ruskes
    Oct 10, 2014 at 0:11
  • possible duplicate of How to fix broken EFI partition?
    – Ruskes
    Oct 10, 2014 at 0:13
  • I'm actually not sure I was getting rid of a recovery partition and I think I muddles the disk identifier. So I used the zeroDisk command and then the eraseVolume one. That have me a partition that was hfs+ and I tried changing it back to fat32 as above but that didn't work. I copied the Bootlog from the old EFI partition to my desktop. Is there a way to format it properly and I can probably just copy that file over. Im still logged into the mac so if I shut down it's not going to work Oct 10, 2014 at 0:32
  • Thanks for that Buscar but that won't do it for me as I'm stuck on this machine at the minute and I can't unmount the drive. Does anyone know of anyway other that 'gpt' to change the format of the hfs+ to efi, alternatively - is there a way to swap these out as I have that partition on the external ? Essentially I just need to swap out disk0s1 with disk1s1 Oct 10, 2014 at 0:52
  • 1
    here support.apple.com/kb/HT1237 and here support.apple.com/kb/HT4125
    – Ruskes
    Oct 10, 2014 at 1:26

0

You must log in to answer this question.

Browse other questions tagged .