1

I have a problem with my Macbook Pro.

Everything was working fine up until yesterday; I can't start it anymore and it "beeps" once every 5 seconds.

According to the support, this indicates that "no RAM is installed", which is not true.

So I tried to change RAM but I have the same problem. I put the suspect RAM into another computer, and it worked fine.

I Googled but I didn't find a solutions. The Macbook didn't take any knocks, I didn't try to change any RAM (before this problem), there is no reason for this error.

Does anyone have an idea ?

(Macbook Pro 13-inches mid-2012)

  • What does it say about your RAM in the About this Mac? – Ruskes Oct 9 '14 at 22:55
2

Sounds like your Logic (mother) board is done.

You should see your RAM in the About this Mac.

Try resenting the SMC and the EFI.

  • Thanks for the answer. Is there anything i can do to check this ? I can't start the Mac, so i can't check the RAM in "About this mac". And i tried both of these solutions, but it won't start at all :( – Andy Camicci Oct 10 '14 at 11:35
  • 1
    If it does not start even in safe mode then sorry to say, your hardware needs repair (the logic board) – Ruskes Oct 10 '14 at 16:07
0

Perhaps the RAM simply became loose. You said it worked in another computer. Try putting it back in the original and make sure it is all the way in.

  • Thanks for your answer. I tried putting it back but there was no difference. Is there any solution to test if the ram slot is working ? – Andy Camicci Oct 10 '14 at 11:40
0

It is an infuriating problem. If your Macbook still doesn't work then you will need to take it in to an Apple Genius Bar to see if they can help you fix it (or arrange for a repair under warranty). Hopefully you have got enough data from your Mac so as to be able to back up, or continue working on a new Mac.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .