0

Over the last week I have had four similar incidents:

When I played something on YouTube, the audio just loops for a few seconds, and then either the screen freezes or a black screen will appear.

For the first three times, booting up will result in blue screen with black vertical lines, grey screen or black screen. Went to technician at my school for advice, he said to update my Macbook to 10.9.5. I did that, it was fine for around 48 hours or so.

A few minutes ago, I was watching something on BBC iPlayer when suddenly the sound loops and a black screen appeared. I cannot control my keyboard either. I have to long press the power button (force shut down) and started up again. When I boot up the computer it booted up fine, no safe mode needed. Weirdly enough it did not give me any log. turns out it was from YouTube, not iPlayer

Anyone has an idea of what might be going on with my Macbook? I have the early 2011 Macbook Pro model, 15". Could this be one of the infamous cases of bad GPU?
Is it also possible for this incident to happen multiple times in one day?

Thank you in advance.

  • 1
    does it ONLY happens while watching online stuff? and NOT when watching downloaded videos? – Ruskes Oct 8 '14 at 18:48
  • 1
    It only happens when I watch stuff online. Three times from YouTube and once from iPlayer. On Google Chrome flash is already built-in into the browser, so it automatically updates. – wazzupworld Oct 8 '14 at 20:08
  • If you Disable the Adobe Flash player in Chrome, does it work then? – Ruskes Oct 9 '14 at 20:08
1

It is a case of desecrete GPU failure. Most of the Early and Late 2011 MBP are prone to this failure. The culprit is the AMD GPU. See more at the links below.

http://www.digitaltrends.com/computing/suddenly-bunch-early-2011-macbook-pro-owners-running-video-problems/

http://www.cultofmac.com/262861/early-2011-macbook-pros-dropping-like-flies-heat-issues-blame/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .