0

I had time-machine set up to backup to a disk over a network (SMB mount) and all worked fine. I then had some problems with the backup file (became inexplicably locked) and while I was trying to figure that out I clicked on the "Don't use" option in the disk select panel (big mistake as it turns out). The disk disappeared from the list of those available. I subsequently fixed the problem with the backup file. I can now mount it and time machine can see it under "browse other disks". Is there any way I can "undo" the "Don't use" option to make the disk visible again for use as backup? I can't delete/re-install the remote disk so it would need to be something local. Does anybody know where the flag that prevents that disk being displayed is located? (I am running Mavericks on an imac).

1

An excellent question. There may be a file on your backup drive called .com.apple.timemachine.donotpresent. Remove it, if it's there, and that should solve your problem. The file is invisible, so you'll have to use Terminal's rm to remove it.

However, with SMB, Time Machine doesn't support it natively, so you may have to run this command in Terminal for the drives to appear. Be sure to restart System Preferences.

defaults write com.apple.systempreferences TMShowUnsupportedNetworkVolumes 1 && killall Finder

  • Thanks for the suggestion. TMShowUnsupportedNetworkVolumes was already set (the backup was working). There is no .com.apple.timemachine.donotpresent file on the backup drive. I also tried deleting the relevant plist file from the system library to force time-machine to do a complete reset. No joy. – Alan_K Oct 9 '14 at 9:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .