3

I have installed a few profiles from third-parties, now I'd like to remove them from General - Settings - Profiles, which is the way I did before prior to iOS 8. However, I don't see them there on my iPhone/iPad(iOS 8.0.2) any more.

Is this something new from iOS 8? Any clue how to remove my installed profiles?

ps. I know I can remove profiles from Xcode - Devices. But that's only for the ones installed with my associated development account. I need a general way to remove all of them.

2

According to a StackOverflow answer here, "If the provisioning profile is expired, iOS should get rid of it automatically. As apps are deleted, iOS should properly deal with the provisioning aspects automatically. This philosophy is mentioned in WWDC 2014's talk on Managing Apple Devices around ~42 minutes in."

I just uninstalled GBA4iOS and the provisioning profile is still there, even after a reboot. I don't know where to look to see it on the iPad without connecting it to a computer w/ XCode, so I ask my MDM to report on it. Still researching..

[edit] here is the phrase from the WWDC talk: "Provisioning profiles no longer appear at all in Settings because its handled completely automatically. The device will automatically prune expired provisioning profiles when they are no longer needed."

Still looking for a way to UnTrust a Provisioning Profile without xCode..

3

I know this is an old thread. I have been experiencing the sam issue with students downloading apps through 3rd party. The provisioning profiles are still on the device, despite them being removed through settings etc..

Once the update 10.2.1 was complete they no longer exist on the device as seen through the our MDM, Xcode or the device itself..

So updating to new OS worked for me.. Hope this helps anyone

1

in order to see "profiles" again in settings, I went to beta.apple.com/profile & it installed a profile in order to update to software 9.1 (Beta).

Profiles is showing again in settings!!!

Note: I'm using iOS 9.0.2 & this method worked for me (:

0

Device restoration might just be the only answer, as I've had the same problem when upgrading from iOS 6 to iOS 7. I tried everything, to no avail.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .