3

I'm trying to use Swift on Xcode 6 for an OS X application, but it defaults the language to Objective-C and won't let me switch it to Swift. I can use Swift for iOS but not OS X. I have the latest software so I'm not sure what the problem is. Can someone help?

3

The current version of Xcode doesn’t support Swift for OS X… yet.

The App Store update description says:

* NOTE: Swift support for OS X is coming in a future Xcode update

So you'll either have to download the beta version from http://developer.apple.com/xcode/downloads or wait for support to be added for the release channel.

0

Swift is currently supported by 2 versions "XCode Ver. 6.4" and the latest "XCode 7 Beta 2 Ver."

Download Either of them from http://developer.apple.com/xcode/downloads

XCode 6.4 Recommended as of now due to stable release.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .