I've encountered a somewhat strange problem on my Mac. Recently, all the devices listed in the 'Shared' section of the Finder sidebar have all disappeared and has been replaced an 'All..." option.

Strangely within this option the shared servers don't even appear there. Instead there is a folder called 'Servers' and within that are two shortcuts that lead to the root drive of my Mac (which is named "glados" on the network).

Finder screenshot of shared drives

However, on another mac on my network, things seem all fine and dandy there. It even picks up the troubled Mac (which appears as 'Javan's MacBook Pro' thanks to bonjour) and appear in both the sidebar and the Network folder.

Finder screenshot of shared drives on a different Mac

Before shots get fired, Yosemite has nothing to do with this. I've troubleshooted for hours and hours and have come to the conclusion that it is not the cause.

I've verified that the network settings are the same on both Macs (and they are) and I've even used a program called 'Bonjour Browser' to scan the network for the AFP share service on both Macs and both can detect each other (and themselves) on the network.

Bonjour Scanner

So I'm pretty sure its not a network issue since the iMac can see the MacBook fine and the MacBook can 'technically' see the iMac.

Also, if I manually connect to a shared drive on one of the PC's or the iMac via 'Connect to Server' the connection is fine and appears on the sidebar (however its named as the IP address of the shared drive and is only temporary as it disappears as I disconnect, which is totally useless)

Connected manually to an SMB share

I've reverted back using Time Machine to when the MacBook was running Mavericks and the problem still existed. So it leads me to believe somethings gone wrong with some sort of preferences file perhaps? I've tried deleting com.apple.finder.plst in the ~/Library/ directory and relaunched but that didn't help either.

I'm fresh out of ideas, and other existing forums on the rest of the internet haven't seemed to fix it. If anyone has a remote idea any help would be appreciated! Thanks internet! :D

PS. Soz for the screenshot overload.

Edit: I forgot to mention that I have made sure that all 3 options are checked in the Finder Preferences for the shared sidebar (Back to my Mac, Connected Servers and Bonjour Computers)

  • Are the settings the same in Finder --> Preferences --> Sidebar --> SHARED. With all three boxes checked, "Back to My Mac", "Connected Servers", "Bonjour Computers".
    – tron_jones
    Commented Oct 7, 2014 at 12:33
  • Yeah they're checked. It's actually one of the first things I tried to do. Forgot to list it in the question. Oops Commented Oct 7, 2014 at 12:34
  • Oddly enough I can reproduce this as well. The only way I can get it to work and show in the sidebar is by turning off Wi-Fi. I'm on a network with a couple hundred machines so the list is very long. Once I turn off Wi-Fi the sidebar shows properly........Turn Wi-Fi back on and they disappear.
    – tron_jones
    Commented Oct 7, 2014 at 14:29
  • 1
    I get the same thing too when I move over to my work with a large network. Thing is though this is my home network with like another 4 or 5 other machines on there. They even don't appear in the 'All' or 'Network' windows. Plus I'm on ethernet. WiFi is currently off. Gigabit ftw! Commented Oct 7, 2014 at 21:29
  • 1
    That hasn't seemed to fix it either. The problem is more than just the sidebar though. The devices aren't even appearing in Network. When I click on 'All...' there's nothing there except a servers folder that takes me to my drive inside my laptop. Somethings stopping the devices from appearing in both the sidebar AND the network folder Commented Oct 16, 2014 at 14:04

6 Answers 6


I found a fix. I had the same problem after installing OS X Server.

Simply put, I did the following:

  1. Go to ~/Library/Preferences and find the plist file, depending on your version of macOS:

    • com.apple.sidebarlists.plist
    • com.apple.locationmenu.plist
  2. Copy the file for backup purposes and open original with Xcode

  3. Leave the following items and delete the rest:

    • finderprojects
    • favoriteitems
    • systemitems
    • savedsearches
  4. Go to the Apple Menu > Force Quit... and relaunch Finder (which really did nothing but I did it)

  5. Shutdown/Restart your Mac so the changes to take full effect.

Now I can see my network devices under Shared in the sidebar.

  • This actually makes sense, I recently installed OS X Server at the time. It didn't occur to me that that could have been the cause of any of it though at the time. Commented Dec 29, 2014 at 11:31
  • 1
    In Mojave "Shared" is called "Locations" and the corresponding file might be ~/Library/Preferences/com.apple.locationmenu.plist, however mine–except for XML declaration–seems to contain an empty plist <plist version="1.0"><dict/></plist>
    – MikeiLL
    Commented Oct 8, 2019 at 15:41

I had the same missing shared device problem. I actually stumbled into a quick fix.

  1. In Finder select "Go" then "Connect to Server"

  2. In the dropdown list on the right side to the right of the server address there's a drop-down icon. I clicked on it and it showed a "Recent Servers" list. I figured I'd see if an old connection would work. I clicked on one of the "Recent Servers" and it worked. (I didn't have to put afp://<shared device name>> or IP address or anything in the server address field)

  3. weirdly/magically/cosmically, the "Shared" section in Finder instantly re-populated itself with the other missing devices I used to see on my network. All of them.

Don't ask me why, but I don't feel like wasting any more time on it and it was super easy. Perhaps it forced a refresh of the plist or something.....

  • I always used the disks in the "Recent Items" in the Apple drop down menu (which uses the same function as the "Connect to Server" recent's list essentially) as an alternative to not being able to access the servers via Finder, in conjunction with direct connections via "Connect to Server". This never seemed to solve my issues and I don't believe that it would cause a forced refresh of the plist as carrying out these tasks would have no benefit of a forced refresh after you carry out the task Commented Feb 4, 2016 at 2:24
  • Whenever I use the Connect to Server, my other computer shows up on the list whereas Finder does not show it in the sidebar. Therefore this option works wonders if you previously connected but Finder is being a stickler and not showing an existing network place.
    – Zlatty
    Commented Nov 3, 2016 at 0:30
  • 2
    This worked for me too. No macs in the house could see the shared folder on my main computer. After your suggestion, every mac could see it. Commented Sep 27, 2017 at 19:35

A much simpler way is to delete the plist, reboot and reconfigure. I have the same problem after upgrading to 10.11 and this fixed it.

  1. Go to: ~/Library/Preferences
  2. Move the file named com.apple.sidebarlists.plist (and com.apple.sidebarlists.plist.lockfile if there is one) to the Trash.
  3. Reboot.

The plist will regenerate and you can go to Finder > Preferences > Sidebar to reconfigure.


If you follow the step just above of deleting com.apple.sidebarlist.plist, then empty trash (it will say you can't delete com.apple.sidebar.plist because it is in use) click continue, then force quit Finder.

After a few seconds the Shared (network) list starts to rebuild.

I agree with SteppingHat it is always better to find the root cause of the problem, but rebuilding the plist does 'fix' the problem when you don't have the time (or skills) needed to delve into the problem.

At least you do not necessarily have to reboot as a result!


My missing drive is attached to a shared server as well. Went to the drive on the server and clicked it and keyed Cmd/I (info). I found an unchecked "Shared" box under the General tab.


In my case this appears to have been caused by a Double NAT situation.

I have a T-Mobile Home Internet gateway plugged into my router to provide the internet service. All computers were connected to the inner network of the home router. Routing cannot be turned off on the LTE gateway, unfortunately.

I now switched the AirPort Extreme Router Mode to Off (Bridge Mode) via AirPort Utility. Also known as Access Point mode. All routing is now done by the T-Mobile box instead.

The other Mac is now visible in the Network sidebar of Finder. Screen Sharing works. Double NAT seems to cause the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .