3 weeks ago I installed Yosemite public beta onto a brand new Macbook Air which arrived with Mavericks pre-installed. To carry out the installation I created a new partition for Yosemite and so had the option of a dual boot.

Last week the public beta 4 came through and my existing Yosemite partition was not big enough to allow installation.

I figured that because it was a brand new machine with no data to be lost I could risk using Yosemite as my only OS, and so I decided to remove Mavericks with the intention of having one single partition with Yosemite. What has happened is that I have now 2 partitions - one prescribed Macintosh HD and the other my Yosemite partition. But I am unable to merge the two partitions or to grow the Yosemite partition from it's initial 20Gb, furthermore the partition entitled Macintosh HD is inaccessible.

Diskutil showing partitions

Through using Terminal commands I was able to resize the Macintosh HD, but I am still unable to resize the Yosemite partition drive.

Drive partitions - terminal

I have discovered that then Yosemite partition was made into CoreStorage, and so have used the Terminal commands to try to resize this - both the Logical Volume Group and the Physical Volume - but the Physical Volume command reports the volume is too small to be made larger, whilst the resizeStack command on the Logical Volume Group generates the following report "60DF5D65-41F2-41D1-A56E-9C74FFFD3E6D does not appear to be a valid Core Storage Logical Volume UUID or disk"

CoreStorage Partition

  • Hi there I appreciate that Yosemite is off topic, but that is not my problem, my problem is in understanding the issues with partitions on the hard drive, which I believe are the same for Mavericks.
    – timvickers
    Commented Oct 7, 2014 at 18:10
  • Can you wipe the drive in question and reproduce things on 10.9? You also might just need to boot to Recovery HD and back up both volumes to an external drive and then start over with the correct partitioning. We are pretty strict on Yosemite, but it should be out soon :-)
    – bmike
    Commented Oct 7, 2014 at 18:32
  • Thanks, somehow I managed to miss all the warnings about not asking questions about pre-release software...anyway I got an answer below along the same lines as yours and this seems to have done the trick. Really grateful for the help.
    – timvickers
    Commented Oct 7, 2014 at 18:49
  • It's a great question and let's leave it open for now since it's more in the vein of "getting back to a stable situation" than running with 10.10 the more I look at it.
    – bmike
    Commented Oct 7, 2014 at 19:01

2 Answers 2


Boot into Recovery HD, open Disk Utility. Choose Yo Drive in the list and select the Restore tab. Make Yo Drive the Source and Macintosh HD the Destination. This will erase all content on Macintosh HD and replace it with the contents of Yo Drive. Back up anything important on Yo Drive before hand in case of failure during the restore. After that you should be able to erase the second partition and extend to take up the whole drive.

  • 1
    Fantastic - worked exactly as you said and all is now fixed and fine. I am so grateful for your quick and helpful response.
    – timvickers
    Commented Oct 7, 2014 at 18:44

Launch the Terminal and type:

diskutil resizeVolume

You'll see parameter options you can choose and go from there.

  • 2
    The answer provided by tron_jones was accepted by the OP as having solved his problem. If you wish to expand your answer to this question and explain how using diskutil from the command line can be an alternative solution and why someone may choose it over Recovery Mode, then that would likely be a useful addition for future readers. However, your answer, as it currently stands provides very little in additional information or a tutorial that can help someone not familiar with this command line function. Thank you.
    – AMR
    Commented Aug 10, 2015 at 1:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .