1

I have a four year old MacBook Pro with 8 GB of memory. Two years ago I upgraded the hard drive to an SSD. It has been working very reliably, only needing a restart every few months.

Then I updated to Mac OS 10.9.5, and I immediately started having problems with applications hanging, usually while launching. Some app icons will bounce in the Dock for a few minutes, then stop bouncing and they will show "Application Not Responding" when I right-click the icon. Other apps will launch and run for a while, then suddenly hang when I am using them, showing the spinning beach ball icon indefinitely. Other applications are totally unaffected and work with no problems.

Nothing is written to the system log when the applications hang. When I force-quit an application that hung before it finished launching, I don't get a crash report, and a line like this is written to the system log:

Failed to write crash history to file:///Users/arlo/Library/Application%20Support/CrashReporter/_8D064DB0-1D30-5A2E-AFBD-1EF47EA4FA1C.plist.`

When I force-quit an application that hung after it finished launching, I get a crash report like this, from Super Duper. Note that the "duration" shown in the crash report is 4.44 seconds, but the application was actually showing the spinning beach ball for about 10 minutes before I quit it:

Date/Time:       2014-10-06 21:05:47 -0700
OS Version:      10.9.5 (Build 13F34)
Architecture:    x86_64
Report Version:  18

Command:         SuperDuper!
Path:            /Applications/SuperDuper!.app/Contents/MacOS/SuperDuper!
Version:         2.7.2 (92)
Build Version:   3
Project Name:    SuperDuper!
Source Version:  01167
Parent:          launchd [172]

PID:             4218
Event:           hang
Duration:        4.44s
Steps:           43 (100ms sampling interval)

Hardware model:  MacBookPro6,2
Active cpus:     4
Fan speed:       5117 rpm

Free pages:      114577 pages (+531)
Pageins:         1689 pages
Pageouts:        0 pages
Swapins:         0 pages
Swapouts:        0 pages


Process:         SuperDuper! [4218]
Path:            /Applications/SuperDuper!.app/Contents/MacOS/SuperDuper!
Architecture:    i386
Parent:          launchd [172]
UID:             503
Task size:       4029 pages

Thread 0x177893   priority 46        
43 ??? (SuperDuper! + 7461) [0x2d25]
43 NSApplicationMain + 1165 (AppKit) [0x987c2ff8]
  43 -[NSApplication run] + 727 (AppKit) [0x987da15c]
    43 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 119 (AppKit) [0x987e7870]
      43 _DPSNextEvent + 1602 (AppKit) [0x987e8349]
        43 _BlockUntilNextEventMatchingListInModeWithFilter + 92 (HIToolbox) [0x9a4586bd]
          43 ReceiveNextEventCommon + 163 (HIToolbox) [0x9a458777]
            43 RunCurrentEventLoopInMode + 259 (HIToolbox) [0x9a458b5d]
              43 CFRunLoopRunInMode + 123 (CoreFoundation) [0x92c6984b]
                43 CFRunLoopRunSpecific + 394 (CoreFoundation) [0x92c699ea]
                  43 __CFRunLoopRun + 1779 (CoreFoundation) [0x92c6a353]
                    43 __CFRunLoopDoTimers + 349 (CoreFoundation) [0x92d2d06d]
                      43 __CFRunLoopDoTimer + 1395 (CoreFoundation) [0x92cb2863]
                        43 __CFRUNLOOP_IS_CALLING_OUT_TO_A_TIMER_CALLBACK_FUNCTION__ + 22 (CoreFoundation) [0x92cb2ea6]
                          43 __NSFireDelayedPerform + 422 (Foundation) [0x9399e53c]
                            43 ??? (SuperDuper! + 63867) [0x1097b]
                              43 ??? (SuperDuper! + 64409) [0x10b99]
                                43 ??? (SuperDuper! + 64950) [0x10db6]
                                  43 ??? (SuperDuper! + 73294) [0x12e4e]
                                    43 ??? (SuperDuper! + 20352) [0x5f80]
                                      43 ??? (SuperDuper! + 19484) [0x5c1c]
                                        43 ??? (SuperDuper! + 21599) [0x645f]
                                          43 ??? (SuperDuper! + 31578) [0x8b5a]
                                            43 FSPathMakeRef + 47 (CarbonCore) [0x984c572f]
                                              43 FSPathMakeRefInternal(unsigned char const*, unsigned long, unsigned long, FSRef*, unsigned char*) + 130 (CarbonCore) [0x985306cf]
                                                43 PathGetObjectInfo(char const*, unsigned long, unsigned long, short*, unsigned long*, unsigned long*, char*, unsigned long*, unsigned char*, unsigned long*) + 203 (CarbonCore) [0x9851e067]
                                                  43 __getattrlist + 10 (libsystem_kernel.dylib) [0x92e71042]
                                                   *43 hndl_unix_scall + 216 (mach_kernel) [0xffffff80002f3e68]
                                                     *43 unix_syscall + 471 (mach_kernel) [0xffffff80006409a7]
                                                       *43 getattrlist + 191 (mach_kernel) [0xffffff80003c3baf]
                                                         *43 ??? (mach_kernel + 1835607) [0xffffff80003c0257]
                                                           *43 vnode_getattr + 119 (mach_kernel) [0xffffff80003fc6f7]
                                                             *43 afpfs_vnop_getattr + 92 (afpfs) [0xffffff7f8274ea99]
                                                               *43 afpfs_lock + 89 (afpfs) [0xffffff7f82742ba0]
                                                                 *43 lck_rw_lock_shared_gen + 118 (mach_kernel) [0xffffff80002d5766]
                                                                   *43 thread_block_reason + 204 (mach_kernel) [0xffffff8000235d5c]
                                                                     *43 ??? (mach_kernel + 223579) [0xffffff800023695b]
                                                                       *43 machine_switch_context + 354 (mach_kernel) [0xffffff80002d8452]

Thread 0x1778a6   DispatchQueue 2702260908 priority 48        
43 _dispatch_mgr_thread + 52 (libdispatch.dylib) [0x971e6532]
43 kevent64 + 10 (libsystem_kernel.dylib) [0x92e72992]
 *43 ??? (mach_kernel + 3960080) [0xffffff80005c6d10]

Thread 0x1778d9   priority 63        
43 thread_start + 34 (libsystem_pthread.dylib) [0x9064ecf2]
43 _pthread_start + 130 (libsystem_pthread.dylib) [0x90649485]
  43 _pthread_body + 144 (libsystem_pthread.dylib) [0x906495fb]
    43 __NSThread__main__ + 1426 (Foundation) [0x939a1126]
      43 -[NSThread main] + 45 (Foundation) [0x939a11ce]
        43 +[NSURLConnection(Loader) _resourceLoadLoop:] + 381 (Foundation) [0x939a1355]
          43 CFRunLoopRunInMode + 123 (CoreFoundation) [0x92c6984b]
            43 CFRunLoopRunSpecific + 394 (CoreFoundation) [0x92c699ea]
              43 __CFRunLoopRun + 1393 (CoreFoundation) [0x92c6a1d1]
                43 __CFRunLoopServiceMachPort + 169 (CoreFoundation) [0x92c6abf9]
                  43 mach_msg_trap + 10 (libsystem_kernel.dylib) [0x92e6cf7a]
                   *43 ipc_mqueue_receive_continue + 0 (mach_kernel) [0xffffff80002167d0]

Thread 0x1778db   priority 46        
43 thread_start + 34 (libsystem_pthread.dylib) [0x9064ecf2]
43 _pthread_start + 130 (libsystem_pthread.dylib) [0x90649485]
  43 _pthread_body + 144 (libsystem_pthread.dylib) [0x906495fb]
    43 _NSEventThread + 283 (AppKit) [0x98991b88]
      43 CFRunLoopRunInMode + 123 (CoreFoundation) [0x92c6984b]
        43 CFRunLoopRunSpecific + 394 (CoreFoundation) [0x92c699ea]
          42 __CFRunLoopRun + 1393 (CoreFoundation) [0x92c6a1d1]
            42 __CFRunLoopServiceMachPort + 169 (CoreFoundation) [0x92c6abf9]
              42 mach_msg_trap + 10 (libsystem_kernel.dylib) [0x92e6cf7a]
               *42 ipc_mqueue_receive_continue + 0 (mach_kernel) [0xffffff80002167d0]
          1  __CFRunLoopRun + 2130 (CoreFoundation) [0x92c6a4b2]
            1  __CFRunLoopDoSource1 + 523 (CoreFoundation) [0x92c79d7b]
              1  __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE1_PERFORM_FUNCTION__ + 53 (CoreFoundation) [0x92c79e15]
                1  __CFMachPortPerform + 440 (CoreFoundation) [0x92c79fe8]
                  1  MessageHandler(__CFMachPort*, void*, long, void*) + 52 (HIToolbox) [0x9a461726]
                    1  PullEventsFromWindowServerOnConnection(unsigned int, unsigned char, __CFMachPortBoost*) + 99 (HIToolbox) [0x9a4617bd]
                      1  CGEventCreateNextEvent + 39 (CoreGraphics) [0x901697cb]
                        1  CGSGetNextEventRecordInternal + 84 (CoreGraphics) [0x90169864]
                          1  CGSSnarfAndDispatchDatagrams + 167 (CoreGraphics) [0x90169a25]
                            1  _CGSGetPortStreamInline + 127 (CoreGraphics) [0x90169c6c]
                              1  mach_msg_trap + 10 (libsystem_kernel.dylib) [0x92e6cf7a]
                               *1  ipc_mqueue_receive_continue + 0 (mach_kernel) [0xffffff80002167d0]

Thread 0x1778fa   priority 46        
43 thread_start + 34 (libsystem_pthread.dylib) [0x9064ecf2]
43 _pthread_start + 130 (libsystem_pthread.dylib) [0x90649485]
  43 _pthread_body + 144 (libsystem_pthread.dylib) [0x906495fb]
    43 __select + 10 (libsystem_kernel.dylib) [0x92e71ace]
     *43 ??? (mach_kernel + 4080224) [0xffffff80005e4260]

Thread 0x17e852   priority    0-46  
43 start_wqthread + 30 (libsystem_pthread.dylib) [0x9064ecce]
43 __workq_kernreturn + 10 (libsystem_kernel.dylib) [0x92e72046]
 *43 wq_unpark_continue + 0 (pthread) [0xffffff7f80bcb6ae]

(cut)

Once an app hangs and I force-quit it, I can never launch that app again until I restart the computer.

I booted to the Mac OS restore screen (Command-R) and reinstalled the OS, but I'm still having the same problems.

Can anyone suggest some next steps for resolving this?

Examples of affected apps: Finder, iTunes, Time Machine (status shows "Preparing Backups" indefinitely, and Time Machine control panel hangs when launching), Photoshop CS6, Transmit, Super Duper

Examples of unaffected apps: Mail, Safari, BBEdit, Dreamweaver CS6, Xcode 5-6, Android Studio

Update 1: Here's what else I've tried: rebooted from the system CD and ran the extended hardware test, verify disk and verify/repair disk permissions; created a new user account and ran some apps there, which led to the same problems; booted into safe mode, where the same problems appeared; booted with Command-R and reinstalled OS 10.9.5 again. If the problem is not the hardware, not something in my user account and not something in the operating system, what else could it be?

Update 2: I managed to get most of my computer backed up to an external drive, then booted a different computer from that drive. I was able to run through all the affected apps and tasks with no problems. So that makes it seem like a hardware problem, although something that only became apparent after installing OS 10.9.5. I've made a Genius Bar appointment for next week to see if they can diagnose it. If a new hard drive or memory chip would solve my problems, I'd be happy.

Update 3: I took my computer to the Apple Store, and the Mac Genius thought the problem was either with the memory chips or the memory slots. She offered to run a more thorough memory test, but I'd have to leave my computer for 24 hours for the test and another 3-5 days if the problem was with the slots. I had some different memory chips at home, so instead, I took the computer home and swapped the memory. The problems continued. I think the next step is to leave it with the Genius Bar for a likely hardware repair.

Update 4: My computer passed the memory test at the Apple Store, but failed the hard drive test. That's actually one of the first things I thought of when the problem started, because I have often seen hard drive failures after about two years of use, but I read a little about SSDs and got the impression that when they failed, they failed suddenly and totally. I'll order a new hard drive and will post a final response if that fixes the problem.

Update 5: Strangely, since the diagnosis of a failed SSD, I haven't seen the problem again. To get a second opinion, I bought a hard drive test application and it said the hard drive was fine and not far into its expected lifespan. I don't want to replace the SSD if I don't have to, and this is no longer my main computer because I ended up buying a new one to avoid the downtime this problem was causing me. So I guess I'll just leave it as is. What a mystery.

closed as too broad by bmike Sep 30 '17 at 17:15

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

1

You seem like an advanced user (a few developer apps), so forgive me for stating the seemingly obvious, but you did ask… A reasonable course of action would be to try these in the order given (least disruption & work -> most).

1) Use Utilities>Disk Utility to:

  • check/repair permissions on the start up volume
  • verify/repair the SSD volume

2) If you have it, use Disk Warrior to check/re-build your disk directory.

3) If neither of those turn up anything &/or don't fix the problem(s) then you could try re-installing using the 10.9.5 Combo Updater.

4) If you still have problems then perform an (extended) Apple Hardware Test which can be accessed on the install media that (should have) came with your Mac. It sounds like your Mac is old enough to have still come with install DVDs. Whatever media you have (including none), shutdown, disconnect everything but the mouse & keyboard and then startup holding down the 'D' key.

If you have another h/w checking utility (e.g. AppleJack>MemTest, Tech Tool Pro) then try it.

5) If nothing comes of that, then I'd do a clean re-install (after making a complete backup of your Mac). Then use Migration Assistant to transfer your data from the backup media to your Mac's SSD volume(s).

If it's still not fixed, you should probably get it serviced (or I would).

I haven't explained any of these steps in detail 'cause I think you should be able to do them all with help from Google and you may have already done some or all of them, in which case I again apologise. I'm only suggesting these because you hadn't said what you'd already done and I don't know if there's any assumption on here of what you would have done before asking a question like this.

Hope this helps!

  • I had previously reinstalled the OS from the recovery screen. Just now I tried running the hardware test from the system CDs (no problems found), verified the disk and disk permissions with Disk Utility (no disk problems found, a few permissions problems with Safari and iBooks that were repaired) and reset the PRAM. No fix yet. I can't easily wipe the hard drive and do a complete reinstall because both of my backup systems, Super Duper and Time Machine, are broken. I might be able to use a separate computer to back up this computer's hard drive in target disk mode. – arlomedia Oct 8 '14 at 23:31
  • I'm going to try reinstalling the OS again tonight, then I'll either make a Genius Bar appointment for next week, or wait until Yosemite is released and try installing that. – arlomedia Oct 8 '14 at 23:33
  • I don't think there's much use doing anything less than a clean install now, so I hope you can get a full backup of your disk by putting your machine in Target Disk mode. Good luck! – GAM Oct 10 '14 at 2:05
0

I have the same problem, although it mostly occurs when I put an older, potentially faulty DVD in the drive - VLC locks up and refuses to start and I have to reboot, but its also happened with TextEdit, Disk Utility, etc. The behaviour of the applications is the same - you can't kill them, either using the Dock, Force Quit or even sudo kill -9. I have to reboot the machine to recover - and in fact, it won't soft reboot at all, I have to do a hardware power off.

Using sudo spindump you can see that its locked up a mutex in getattrlist which has been reported elsewhere on the web as well. Search Google for 'getattrlist hangs', as there are variety of reports since 2010 for different reasons.

My own spindump is below:

*999 getattrlist + 159 (mach_kernel) [0xffffff80003c3b8f]
*999 namei + 1460 (mach_kernel) [0xffffff80003d5a74]       
*999 lookup + 829 (mach_kernel) [0xffffff80003d61fd]
*999 lookup_handle_found_vnode + 191 (mach_kernel) [0xffffff80003d5c3f]
*999 lookup_traverse_mountpoints + 304 (mach_kernel) [0xffffff80003d6a30]
*999 VFS_ROOT + 198 (mach_kernel) [0xffffff80003faa36]
*999 cd9660_root + 90 (cd9660) [0xffffff7f8217d99b]
*999 cd9660_vget_internal + 107 (cd9660) [0xffffff7f8217dd27]
*999 cd9660_get_hashed_node + 36 (cd9660) [0xffffff7f8217b533]
*999 lck_mtx_lock + 653 (mach_kernel) [0xffffff80002d18fd]
*999 lck_mtx_lock_wait_x86 + 384 (mach_kernel) [0xffffff80002d6560]
*999 thread_block_reason + 204 (mach_kernel) [0xffffff8000235d5c]
*999 ??? (mach_kernel + 223579) [0xffffff800023695b]
*999 machine_switch_context + 354 (mach_kernel) [0xffffff80002d8452]

I've filed bug report #18917691 with Apple. Visit http://bugreport.apple.com, create an account and put in the details of your problem there. You should also upload a spindump.txt file (usually stored in /tmp). Unfortunately, Apple's bug reporting is not publicly-visible, so each individual submits a single ticket each.

If you file a bug report, you can probably also mention it's a duplicate of my ticket number (#18917691). If enough people report the issue, then Apple is more likely to take steps to address the issue and reduce the number of lockups that other people experience.

  • I've filed bug report #18917691 with Apple - bugreport.apple.com - do the same if its important to you. – Nigel Sheridan-Smith Nov 8 '14 at 6:05
  • Welcome to Ask Different. While we appreciate your contribution, this is not an answer to the question, it is an "I'm having this problem, too" statement that should be left as a comment. Once you have sufficient reputation, you will be able to post comments. In the meantime, please edit your answer to include the information about filing a bug report, as this will bring it closer to being steps toward answering the question. – tubedogg Nov 8 '14 at 7:52
  • No prob @tubedogg – Nigel Sheridan-Smith Nov 9 '14 at 4:08
  • Thanks for the info. I tried testing this theory, but by that time, I was no longer able to reproduce the problem. After a month of constant crashes, it seems to have disappeared for no reason that I can determine. Sheesh. – arlomedia Dec 4 '14 at 8:04
0

I went through the gyrations above and narrowed my problem down to issues with sound, so I removed or disabled every sound file & function I could. I also discovered that, after a DiskWarrior run, if I started in safe mode and ran the machine for a couple of days, when I returned to regular mode, the freezing problems had disappeared. BTW safe mode disables sound.

Not the answer you're looking for? Browse other questions tagged .