iOS 8 & 7, iPhone 5S
I have one phone number my iPhone insists ought to be iMessage-capable. The system is actually an automated response-counter I need for work to confirm I have received job details, & has never been associated with any Apple device.
I don't know that device's specifics & probably will never be able to find that information, so all I have to go on is "it never was a number associated with any Apple device or service".

At least in iOS 7 I could switch to Airplane mode, send my text, wait for the immediate error, then switch off Airplane mode, Send Again & it would go as 'green' SMS. In iOS 8 this no longer happens - instead it sends again as 'blue' iMessage which never arrives.

So, the question, to which I'm sure the answer is "can't be done" is
How do I stop my iPhone sending iMessages to that number?

Late Edit:
Though nothing appears to have changed in my setup, in recent weeks [perhaps since iOS 8.1.1], though these messages still send "in blue" they are actually now successfully arriving at their intended destination.

Very late edit:
The reason it now works in blue is because they now actually have an iCloud account associated with the number.

  • Turn off iMessage instead... Settings > Messages. Someone at some point associated that phone number with an appleId which is why it's trying.. too bad they didn't realize the ramification and delete it after they decided to take another route with whatever process they were creating using a different service.
    – Tyson
    Commented Oct 7, 2014 at 0:34
  • BTW... I had that problem for a year with one of my regualr contacts that was using a droid due to a crack screen issue, finally that person got another iPhone tho-- you can also wait awhile until it error and then resend it and it will go green.
    – Tyson
    Commented Oct 7, 2014 at 1:00
  • Another work around if you can text from different number is to get the google voice app and a google voice phone number to go with that aoo and use that app to text your work.
    – Tyson
    Commented Oct 7, 2014 at 1:02
  • Turning off iMessage to resolve an issue with one number is like burning a building down because a cabinet in one of the rooms needs to be repaired.
    – tubedogg
    Commented Oct 8, 2014 at 5:43
  • Anyway, to the original poster...do you have "Send as SMS" enabled in Settings > Messages? I don't remember disabling this option in iOS 7 or before, but it is disabled on my phone after upgrading to iOS 8, so you might want to check. If you enable it, this may allow you to resume using your prior workaround.
    – tubedogg
    Commented Oct 8, 2014 at 5:45

1 Answer 1


See if you can opt that SMS number out of iMessage entirely at https://selfsolve.apple.com/deregister-imessage as explained in more detail at How do I disable iMessage for a contact who no longer has an iPhone

If that doesn't work, contacting AppleCare to enlist the support of an engineer might be needed. In the short term, you can disable iMessage entirely and SMS functionality should be restored for all SMS eligible costacts, but you lose iMessage for everything else as well.

  • The essential problem is that there is nothing I can do from my side; it relies on the other party to do that. I'm not that close to them; it's an agency, they send work, I accept, we all get paid. They maintain it's never been associated with any Apple account, it's a call-counter, attached to a computer. I've been struggling with just this one number for 2 years now :( Every iOS upgrade makes the process more difficult. Used to be able to hold send for 3s in iOS6, in 7 you had to switch to aiplane mode & it would error. iOS 8 neither of those work; I have to disable iMessage, then re-enable.
    – Tetsujin
    Commented Nov 11, 2014 at 14:22
  • Yup - your only levers are disabling iMessage or contacting engineering if the web form doesn't work.
    – bmike
    Commented Nov 11, 2014 at 14:25
  • If I disable iMessage, it's me that suffers - they don't care, they don't have iMessage. The engineers won't talk to me about someone else's number, so I can't try that approach. I need a unilateral solution & there simply doesn't appear to be one.
    – Tetsujin
    Commented Nov 11, 2014 at 14:28
  • Why so negative? Pay or negotiate with the person running the SMS to relay you the confirmation code. If you explained the situation to the Apple engineer, perhaps it's a bug in Apple's code that they would be interested in fixing. Whether these options are worse than your current suffering is something you seem to judge as higher.
    – bmike
    Commented Nov 11, 2014 at 15:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .