I'm not sure what happened but I noticed recently that the Cover Flow icon previews were missing from my files in Finder. I'm using OSX 10.6.7. See the screenshot below - I'm expecting a preview of the file to be shown rather than the black document icon.

How can I get the preview back? The View Options have "Show Icon Preview" ticked.

Quicklook still works on individual files, just not in Finder.

enter image description here


Error message reported in Console:

/System/Library/Frameworks/QuickLook.framework/Resources/quicklookd.app/Contents/MacOS/quicklookd: /System/Library/Frameworks/QuickLook.framework/Resources/quicklookd.app/Contents/MacOS/quicklookd: cannot execute binary file

(com.apple.quicklook[5107]): Exited with exit code: 126

Edit 2 Output of command suggested by @jm666

lipo -detailed_info /System/Library/Frameworks/QuickLook.framework/Resources/quicklookd.app/Contents/MacOS/quicklookd

lipo: can't figure out the architecture type of: /System/Library/Frameworks/QuickLook.framework/Resources/quicklookd.app/Contents/MacOS/quicklookd

After seeing the error message, I restored the previous version of quicklookd from my Time Machine backup and the problem was resolved. I'm going to do a clean install of Snow Leopard just to make sure there are no other issues with my system.

  • When you hit spacebar, does a preview come up in quicklook? It looks like you have Adobe Reader installed so maybe that has something to do with it. Do other file types show a preview?
    – styfle
    May 27, 2011 at 2:56
  • When I hit spacebar the quicklook appears as normal. All types seem to work when pressing the spacebar but none show a preview in the icon.
    – Anthony
    May 27, 2011 at 3:27
  • Could you clarify if there are any quicklookd messages in the console app (all messages and system.log) and also check chat quicklookd is actually running. There are two avenues to pursue to resolve this - knowing the status of quicklookd will help narrow down the issue.
    – bmike
    Jun 6, 2011 at 16:01
  • Also - if you make a new user on the mac - does that user's newly created home folder have black icons as well?
    – bmike
    Jun 6, 2011 at 16:39
  • The console is reporting this error: 7/06/11 5:53:58 PM com.apple.quicklook[4195] /System/Library/Frameworks/QuickLook.framework/Resources/quicklookd.app/Contents/MacOS/quicklookd: /System/Library/Frameworks/QuickLook.framework/Resources/quicklookd.app/Contents/MacOS/quicklookd: cannot execute binary file
    – Anthony
    Jun 7, 2011 at 7:54

4 Answers 4


hm. Removing my answer, because not helped.

So - you got a message into Console.log. So, come step-by-step. :)

What return this command?

lipo -detailed_info /System/Library/Frameworks/QuickLook.framework/Resources/quicklookd.app/Contents/MacOS/quicklookd

Should this:

Fat header in: /System/Library/Frameworks/QuickLook.framework/Resources/quicklookd.app/Contents/MacOS/quicklookd
fat_magic 0xcafebabe
nfat_arch 2
architecture x86_64
    cputype CPU_TYPE_X86_64
    cpusubtype CPU_SUBTYPE_X86_64_ALL
    offset 4096
    size 504912
    align 2^12 (4096)
architecture i386
    cputype CPU_TYPE_I386
    cpusubtype CPU_SUBTYPE_I386_ALL
    offset 512000
    size 399280
    align 2^12 (4096)
  • @jm666 - I have only those 2 plugins + a VMWare plugin (I have VMWare Fusion installed). I have no folder in my HOME folder for QuickLook. I have also downloaded and reinstalled the 10.6.7 update and the problem is still happening
    – Anthony
    Jun 7, 2011 at 21:02
  • huh, that is an weird problem than. (btw, mean $HOME/Library/QuickLook, but you're sure checked it). Your LOG message indicate platform problems (64bit vs 32 bit or PPC) but you havent plugins... so - honestly, now havent any idea
    – clt60
    Jun 7, 2011 at 21:08
  • what return this command? lipo -detailed_info /System/Library/Frameworks/QuickLook.framework/Resources/quicklookd.app/Contents/MacOS/quicklookd (see my answer too)
    – clt60
    Jun 7, 2011 at 21:31
  • @jm666 - unfortunately I'm at work now so I can only provide feedback in about 9 hours time.
    – Anthony
    Jun 7, 2011 at 22:19
  • ok, CU morning /at my time :)/
    – clt60
    Jun 7, 2011 at 22:40

Your mac is failing at a pretty low level for Finder to not be able to generate previews so it would be a great time to make sure your backups are safe and current.

When you log in, quicklookd should start and run in the background until Finder asks it to draw those previews for you.

With the information you presented - it's not clear if quicklookd is no longer starting, now has a problem (say with a new plug in or an old one that is now broken with the latest update)

If you are interested in digging into this - do post more details:

  1. Is quicklookd running? (you can see it in activity monitor)
  2. Are there any messages about quicklookd in the console.app? (system.log and All Messages would be good places to start)
  3. Are you running any custom utility software or added any plug-ins to modify quicklook or Finder?
  4. Anything else major changed of late?

You should be able to determine if quicklookd is failing to start or has a problem with a specific plug-in. It's too uncertain to know what went wrong and the steps to fix depend on what has broken.

Edit If quicklookd won't run in a new user and gets the same errors, then reinstalling the OS should write a new quicklook. The plugins you list are probably harmless and you can either try removing them first or reinstalling. I would go the reinstall first, but can't predict which it will be.

  • quicklookd is not running. I have posted the console error messages above
    – Anthony
    Jun 7, 2011 at 8:06
  • no custom software or plugins to modify quicklook or Finder. No major changes other than the usual Software Updates
    – Anthony
    Jun 7, 2011 at 8:14
  • The file somehow got corrupted in the update or just by chance. I would reinstall the os preserving all user and apps just in case something else isn't working. You could copy in that framework and re do the pre binding, but I would hate for something else to be broken too.
    – bmike
    Jun 7, 2011 at 22:28
  • I'm thinking that I'll do a clean install once Lion is released - that will definitely resolve the issue. I'm going to try another suggestion from @jm666 and see how that goes. If that fails I'll probably ensure my backup is up-to-date and do a clean install over the weekend in preparation for Lion in July
    – Anthony
    Jun 8, 2011 at 0:41
  • 1
    I would urge an install of snow leopard. The initial release of any OS has bugs - most of which are unintended consequences on systems with prior damage like yours...
    – bmike
    Jun 8, 2011 at 2:43

Have you tried running "Repair Disk Permissions" from Disk Utility?

In the past I've found that fixed an issue with icons not displaying correctly.

Alternatively look at a tool like Onyx can run a more comprehensive system maintenance, so that might be worth a shot.

  • thanks. I tried both of your suggestions but it did not resolve the problem.
    – Anthony
    Jun 6, 2011 at 0:41

I'd first start with something that doesn't modify any data, to remain least intrusive. Try Command+Option+Esc for the Force Quit Applications window, and relaunch Finder. If that doesn't fix it, I'd probably reboot and test.

The next step for me would be to boot in safe mode, by holding down Shift when you turn on the computer. If it's running 10.5.x or earlier, you'll see a spinning gear and the boot will take some time. 10.6 will show a progress bar. You can get more information on the function of a Safe boot here: http://support.apple.com/kb/HT1564.

If the issue persists passed that point, then I'd likely start manually removing more caches (~/Library/Caches/), or proceed as @BendiLow suggests with permissions, etc. OnyX can help in system modifications, but to date, I haven't seen anything in the app that specifically would affect the Cover Flow index.

  • I tried all of the steps above with no luck. I also created a new user account and the problem occurs in that account as well.
    – Anthony
    Jun 6, 2011 at 8:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .