2

There are two WIFIs at work. One official and one for guests (which is also used to connect to for privat devices like iPhones). I have the same Apple ID and keychain access configured on my private iPhone and the MacBook.

There is a order of WIFIs in the settings to which the device will connect to first. I want to connect the iPhone to the guest WIFI, but the MacBook to the official WIFI. The order of the WIFIs is also synced and changing one will always effect the other one.

Is there a way to disable sync of the order or of a specific WIFI?

3
  • Nope, as long you are using the sync it will do just that- synchronize. What you are asking is to have one item out of sync which will defeat the purpose of syncing the devices while on the same network.
    – Ruskes
    Commented Oct 6, 2014 at 15:23
  • I want to have them syncronized, just not the order in which they should connect to. I fear there's just no option for that yet. Commented Oct 6, 2014 at 15:25
  • 1
    AFAIK you are right, as long there is a sync the WiFi it will do it.
    – Ruskes
    Commented Oct 6, 2014 at 15:30

3 Answers 3

2

I had the exact same problem, and I found this solution to work pretty well for me: By creating a profile that you install into your iPhone, you ensure that only the iPhone will know about the guest network.

Here are the instructions:

  • Install the official "Apple Configurator app" on your Mac-Book: https://itunes.apple.com/app/apple-configurator-2/id1037126344

  • Create a new Profile: Go to File -> New Profile -> Wifi -> Configure

  • Enter the name (SSID), password and security settings for the guest network. You may want to check the Auto Join option.

  • Save the profile File -> Save...

Now delete references to the Guest network from both your Mac and your phone.

  • Finally connect your iPhone to your Mac and install the newly created profile into your iPhone. File -> New Window -> Select your phone -> Click the green + icon -> Profiles

Now only your iPhone will have knowledge of the guest network and your MacBook will never try to connect to it.

It's also working well in the other direction: Once connected to the Guest network through the profile, my phone will never try to connect to my enterprise network even if it's saved in the keychain. Although I can't explain why .. but this seem to do the trick !

0
0

I've come across the same issue. What i did was merely state forget this network (In this case the non guest one) on my iphone.

You can easily do this by navigating to Settings->Wifi->Official WIFI->Forget This Network.

Keychain wont do this on the Mac though. there the order is defined by the Network settings. System Pref -> Network -> Wifi then click "Advanced" on the bottom left and define its order.

Hope this helps.

1
  • When I click on "Forget this network", there's a popup saying that it will also be forgotten by all devices using the same iCloud Keychain. That's exactly what I don't want. Commented Oct 6, 2014 at 13:13
0

Seams like there just isn't any way to do this yet.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .