3

I have searched through this site alot and i wasn't able to find any solutions.

My situation is the following: I decided to install linux to dual boot with OSX at my 1TB fully encrypted with FV2 hard drive. I opened the disk utility and i shrinked the main partition to 500GB. I created another one with 500GB to install linux there. Right after i did that, i changed my mind :S and wanted to expand the OSX partition again to be 1TB. This is what I get - everything is greyed out and I'm not able to do anything: enter image description here enter image description here

I 've tried to reboot and boot with cmd+r to enter the system recovery and run disk utility from there - the results are the same. I 'm desperate:/

  • I have FV2 switched on. I don't know what and how to resize with the cmdline "diskutil corestorage". Could have you got any more specific advice? – murky Oct 6 '14 at 12:21
4

It seems that i did it using this post Unable to Resize Partitions and your comment.

Although it wasn't obvious for me, what I did was this:

diskutil corestorage resizeStack LOGICAL_VOLUME_UUID 0G

0G to expand it to the maximum available space that is free.

diskutil corestorage resizeStack

can provide with info.

  • I cannot find how to mark it as solved :/ – murky Oct 6 '14 at 12:53
  • THANK YOU SO MUCH! I was using resizeStack unsuccessfully because I couldn't find the exact right size to put in and it was creating an invalid volume. I didn't know 0G would just take up all available free space! – swrobel Nov 19 '14 at 20:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .