18

I've installed Yosemite in a second partition. Once I decided to remove Yosemite and go back to Mavericks, I am not able to claim the free space partition in the Disk Utility. How can I reclaim this partition?

  • 4
    It appears you've asked and answered a question in the same post. You're allowed (in fact, even encouraged by some) to answer your own question, but you need to post the question as a question, then post the answer in response to your question, not with the question and answer together in the question section. – Daniel Oct 6 '14 at 1:07
4

I read a lot of blogs, tried different commands and finally got it fixed.

  1. Reboot your Mac in Recovery mode using Command+R key combination during the boot up.
  2. Start Terminal application from the recovery boot
  3. Run command, diskutil cs list
  4. See the last Logical Volume name, 76A3020B-B3C2-4905-9E09-2EBB5470261C

    Use that in next command.

  5. diskutil cs revert 76A3020B-B3C2-4905-9E09-2EBB5470261C

    This should convert the CoreService Logical Volume to a Normal Disk partition.

  6. Run command, diskutil cs list now, and you should receive message that no CS volumes.

  7. Now, Reboot your MacOSX normally and once you login, start Disk Utility and resize your main partition "Machintosh HD" to claim all free space.
  • 2
    This was formerly posted by OP in the question. After numerous years, OP still hasn't moved it to an answer, so I have done so as community wiki as it is still a useful resource. – grg Dec 24 '17 at 19:38
2

grg's answer worked for me, but I'll add some info. Had a problem installing Win10 on a MacBook A1502. It didn't want to install on a Bootcamp partition (GPT problem), then i deleted the bootcamp partition and tried to install win10 into the free space. After this, i was no longer able to boot my MBP under MAC OS - it simply didn't see the system. By the way, Macintosh HD partition decreased in size to 54GB. The second partition was empty (exactly like "empty space") and unable to be attached to Macintosh HD (I mean, Macintosh HD partition was impossible to expand to 121GB). I tried backing up with Time Machine, but it said it cannot restore the system due to lack of space (lol). I tried reinstalling Mac OS (all in Cmr-R), but it said the same. DiskUtility in "Emergency" utilities (I mean, accessible with Cmr-R) could not attach the free space to Macintosh HD. I pressed "+" and selected all of the file systems, but nothing happened.

Terminal did the work. Once you type diskutil cs list, you will see lots of logical storages. Please note that they may have different format (for 76A3020B-... there are two digits first), that will save you time. If you try to revert the wrong partition (not with two digits first), you will get an error. Just do the same but change the Logical Volume name.

  • I had an error during the installation process of Bootcamp. When I exited I deleted the partition in BootCamp (but it said there was a problem). Despite it saying there was an error when deleting, the partition volume is now gone in Disk Utility view. I tried these steps, but none of them seem to work. The Logical Volumes didn't accept the commands. I created a 175 GB partition, deleted it, but can't seem to get the 175 GB back! – Matt May 27 at 4:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .