7

Do not tell me to use this shortcut CTRL + COMMAND + F to exit or enter in the fullscreen mode. I would like to always see the toolbar in the top of the page when I am in fullscreen mode, is it possible?

This Mac default style is completely annoying.

  • 2
    really annoying... – imsrgadich Mar 27 '18 at 20:42
  • 1
    I agree, probably the most annoying thing with mac, apps jump up and down everytime you use the toolbar – Alexander Mills Sep 26 '18 at 16:57
7

I don't think it can be done.

By default, the menu bar will float in if you hover the mouse at the top.

Alternatively, why not just use the window maximised, which will give a very similar look to what you want. [Green dot, top left of any window - though some apps will toggle full screen horizontally & vertically, others only vertically, you'd have to drag the corner for those]

Update for Yosemite, the green button behaviour is now reversed from Mavericks & before…

  • Green dot will set to fullscreen, without the menu bar.
  • Alt ⌥ /Green dot will maximise, leaving the menu bar visible.
  • 1
    The green maximize dot hides the menu bar for me. – Aaron Franke Jul 14 '18 at 17:44
  • 3
    The green dot is not maximise, it's fullscreen, since Yosemite. Opt/green dot is maximise, as already explained. This answer is from 2014. – Tetsujin Jul 14 '18 at 18:38
2

The problem with the suggestions people are offering is that they are NOT full screen mode. When you resize a window it takes over the desktop rather than becoming a separate pane. I like to toggle between screens using a four finger swiping motion on the magic trackpad (the way you do on an Ipad), or alternately, press command ⌘+TAB. You know how. If the apps are not in TRUE full screen, then they appear as part of the desktop screen and you can't toggle between them. You have to minimize one to find the other one beneath it, then bring it back up using the dock. I've lost pages that way when I have more than one screen from the same program open (like two spreadsheets, pdfs, or Word documents). Even when you go to Mission Control only one screen appears, that of the desktop. I sympathize with Rinzler. I hate that you can't have full screen and still see the menu.

The only thing I can suggest to you (just figured this out now) is to try to replicate some of the stuff from your menu bar onto the dashboard and then have a hot key for the dashboard. I suggest the blank F5 key. This will be as close as you can get to bringing up the menu bar with a single press as I can imagine. And you can just as quickly make it go away.

  • i have the exact same problem. i love the 4 finger scroll. but i hate that the menu bar keeps disappearing in fullscreen mode. – Awesome_girl Jan 14 at 4:31
  • This is precisely what Spaces was designed for. Fullscreen breaks Spaces [bad move, Apple] so using maximised & Spaces is a far more graceful solution - see apple.stackexchange.com/questions/179376/… – Tetsujin 15 hours ago
0

My husband showed me how to make it always show up.

Open up your browser and float at the top to get the tool bar.

Click on View, and then "Exit Full Screen."

It will make your browser window half the size of what you will want.

Then use your mouse to put the arrow on the right side of the window and pull it to fill in the right side.

Do the same on the bottom. And any adjustments you want on the top.

Now, quit your browser.

When you re-open it, it should remember and be the exact size you want - with the tool bar in full view.

0

In Safari, enable ViewAlways Show Toolbar in Full Screen.

                         

  • 2
    That only works for some applications and I think the OP meant the top menu instead of the toolbar (which is different depending on the app that's focused). – sebastienvg Aug 31 '16 at 14:20
0

I just figured the solution! You need to adjust the screen in the maximize screen as everyone said but also, click hide on the bottom bar and hide it, that way you get a larger portion of the screen and keep the menu bar on top showing.

I like the menu bar because it keeps showing the time and battery. Not sure how you can live without seeing those two all the time...

0

Answering a question within 5 years of the question being asked was considered fast turnaround in ancient times. So...

The only way to do this is this:

1- Create a new desktop (slide three fingers up, click on the + on top right corner to create a new blank desktop)

2- Un-maximize (Microsoft language: restore) the window or app in question.

3- Drag the window all the way up until all the desktops show at the top.

4- Place the window/app in the desktop you just created.

5- Press Option and click on the green/maximize button of the on the top left corner of the window/app.

The window/app will maximize in that desktop with the menu showing on top as desired (only if the options is unchecked in System Preferences > General > Automatically hide and show the menu bar).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .