1

I have an iPhone 5 with iOS 7 and Tweetbot 2.x, which I purchased a couple years ago. I would like to upgrade to version 3, but their most recent update requires iOS 8, which I have no desire to load at the moment.

Is there any way for me get install a 3.x version that works with iOS 7, or am I stuck until I upgrade to IOS 8?

1

Does the store not give you an option to install the latest compatible version?

According to that article, you should be able to look into your list of purchased apps, and the App Store will ask you if you want to install the latest compatible version if your version of iOS does not support the current version of the app.

It's possible that this will only work for apps that you have previously purchased, but I don't have a device here to test.

  • No, it didn't give me that option. Technically, I haven't purchased version 3 yet. And so I think you might be right, if I had bought it before they published the iOS 8-only version, then the steps in that article would probably work. – Chris Tybur Oct 5 '14 at 23:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .