2

I have been trying for days to get Windows 7, 64 bit installed on my late 2013 Macbook Retina using bootcamp and always run into the same problem - when the Windows installation starts it gives an error message saying "No device drivers were found for my CD/DVD device..." and prompts be to try to browse to a location to find the drivers.

When I try to browse for the drivers I see two drives:

  • BOOTCAMP (C:)
  • BOOT (X:)
    • Program Files
    • sources
    • Users
    • Windows

(C:) is my bootcamp partition and I am assuming that (X:) is my install drive, but the file structure looks nothing like what it looks like from Mac OS X.

I never get the prompt asking me which partition to install Windows on.

I am using a USB drive and a Windows 7 64 bit ISO with Bootcamp Assistant. Everything goes smoothly in BCA. I have tried several different ISOs including one recommendation to use a specific ISO that is supposed to be a "full" version which includes additional drivers, but still with no luck.

3
+100

The (fixed) Pre-Installation Environment (boot.wim) of your Windows_7.iso doesn't contain the necessary drivers to use the USB3-interface of your Late 2013 Macbook Retina. So a "non-standard Windows7.iso" including "additional drivers" without injecting/implementing them into the boot.wim won't help much either. Btw BOOT (X:) is not your install drive but the mounted boot.wim.

To circumvent limitations (new drivers, new hardware) Microsoft uses the $WinPEDriver$-feature to provide drivers at installation time.

Apple Boot Camp uses this method to provide the necessary drivers with the boot medium - your external USB drive.

Please check if you meet the following requirements:

  1. Backup of your entire hard disc

  2. Windows 7.iso Home Premium x64, Professional x64, or Ultimate x64 (these three are us-en digitalriver isos and here is a full list of all images available there). Please use Microsoft Software Recovery to download the proper Winodws 7 release.

  3. Formatting of the USB-device (according to Apple):

    If the size of the disk is 32 GB or less it should be MS-DOS (FAT).

    If the size of the disk is over 32 GB it should be ExFAT.

    Try to use an USB thumb drive (size 8 GB or bigger). If you don't have a thumb drive, try to use an USB hard drive smaller than 2 TB. ExFAT formatting with Apple disk utility.app often doesn't work (means: formatting ends in FAT32 instead of ExFAT) and according to different sources a volume size limit of 2TB exists for MS-DOS (FAT) (=FAT32).

  4. Boot Camp Support Software version: 5.1.5640

    download link: Latest Boot Camp Support Software

  5. File/Folder structure of the root of your boot device (your external USB-drive):

root files and folders

  1. If your boot device doesn't contain $WinPEDriver$, AutoUnattend.xml and BootCamp please download and extract BootCamp5.1.5640.zip and copy the contents of the resulting BootCamp folder to the root level of your install drive.
  2. If your install drive already contains those files and folders then check if the USB drivers are present. (Paths: /$WinPEDriver$/IntelxHCISetup/Drivers/HCSwitch/Win7/x64/ and /$WinPEDriver$/IntelxHCISetup/Drivers/xHCI/Win7/x64/). If they aren't present the wrong Boot Camp Support Software package has been chosen. Delete $WinPEDriver$, AutoUnattend.xml and BootCamp and continue with step 6.

Now the installation should work.

If the installation still doesn't work a more time consuming way has to be chosen (modifying the boot.vim) and i will write a second answer.

P.S. Did you already check this apple.stackexchange question/solution? Especially the comment of user funkylaundry May 18 at 16:38to the 1st answer: "the key was to entirely remove the bootcamp partition and then add it again"

  • Wow, thanks. I will try this out when I get home from work. I saw that link you mentioned before but it didn't really seem applicable (I don't have an optical drive). – mclaassen Oct 9 '14 at 15:36
  • 1
    Wow indeed +10 on that. Where have you been all this time, we need more answers like this one :) – Ruskes Oct 10 '14 at 17:03
  • so did it work? – klanomath Oct 10 '14 at 18:35
  • Worked. The only thing I did different was use a different (never used, 32GB) USB drive. Now there's just the issue of not being being able to swap the fn and ctrl keys under bootcamp... – mclaassen Oct 11 '14 at 18:35
  • @mclaassen blueskyworkshop.blogspot.de/2011/05/… – klanomath Oct 11 '14 at 21:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .