1

After replacing the SuperDrive in my MacBook Pro I copied the Recovery HD to a USB stick and booted from it. Then I ran diskutil cs create MacintoshFusionDrive /dev/disk0 /dev/disk1 (SSD, HDD), reinstalled MacOS from the stick and migrated from my backup.

Unfortunately, I didn't think about keeping the Recovery HD, so I ran from the stick diskutil cs resizeVolume on the logical volume and diskutil cs resizeDisk <UUID> <size> "Recovery HD" <size> on the coreStorage disk of the HDD to make a new partition on wich I then copied the contents of my recovery stick.

Somehow the name of the recovery partition only in the startup menu (alt boot) was localized in German but I got rid of that by running sudo bless --folder /Volumes/Recovery\ HD -label Recovery\ HD. I don't really understand why this happened and how that exact line solved problem. But all seem's fine now. Perhaps I accidentally copied the image on the drive back to the drive directly. Anyhow.

It remains to resolve the last oddity that in the startup hdd menu, there are two Fusion Drives wich both start up the system just fine. It's not a real problem but I would like to know what's causing this and how to get rid of the duplication.

$ diskutil cs list
CoreStorage logical volume groups (1 found)
|
+-- Logical Volume Group 3D7E41ED-2D3B-4C46-A696-2C0C156B6BF6
    =========================================================
    Name:         MacintoshFusionDrive
    Status:       Online
    Size:         625672790016 B (625.7 GB)
    Free Space:   154107904 B (154.1 MB)
    |
    +-< Physical Volume B7097B08-1AD3-4AAA-BD1B-88BF5E0EF57E
    |   ----------------------------------------------------
    |   Index:    0
    |   Disk:     disk0s2
    |   Status:   Online
    |   Size:     127691702272 B (127.7 GB)
    |
    +-< Physical Volume 12F98EE5-AE4C-4A14-8276-7915BCD06999
    |   ----------------------------------------------------
    |   Index:    1
    |   Disk:     disk1s2
    |   Status:   Online
    |   Size:     497981087744 B (498.0 GB)
    |
    +-> Logical Volume Family 5E001AF2-DE08-46C2-A1DA-5637AB534553
        ----------------------------------------------------------
        Encryption Status:       Unlocked
        Encryption Type:         None
        Conversion Status:       NoConversion
        Conversion Direction:    -none-
        Has Encrypted Extents:   No
        Fully Secure:            No
        Passphrase Required:     No
        |
        +-> Logical Volume AC804BCD-419F-4AA0-AE01-1C7D25FF3949
            ---------------------------------------------------
            Disk:                  disk2
            Status:                Online
            Size (Total):          619999997952 B (620.0 GB)
            Conversion Progress:   -none-
            Revertible:            No
            LV Name:               Fusion Drive
            Volume Name:           Fusion Drive
            Content Hint:          Apple_HFS


$ diskutil list
/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *128.0 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:          Apple_CoreStorage                         127.7 GB   disk0s2
   3:                 Apple_Boot Boot OS X               134.2 MB   disk0s3
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.1 GB   disk1
   1:                        EFI EFI                     209.7 MB   disk1s1
   2:          Apple_CoreStorage                         498.0 GB   disk1s2
   3:                 Apple_Boot Boot OS X               650.0 MB   disk1s3
   4:                 Apple_Boot Recovery HD             1.1 GB     disk1s4
/dev/disk2
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  Apple_HFS Fusion Drive           *620.0 GB   disk2

$ sudo gpt -r show disk1
      start       size  index  contents
          0          1         PMBR
          1          1         Pri GPT header
          2         32         Pri GPT table
         34          6         
         40     409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
     409640  972619312      2  GPT part - 53746F72-6167-11AA-AA11-00306543ECAC
  973028952    1269536      3  GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC
  974298488    2212488      4  GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC
  976510976     262159         
  976773135         32         Sec GPT table
  976773167          1         Sec GPT header
$ diskutil info disk1
   Device Identifier:        disk1
   Device Node:              /dev/disk1
   Part of Whole:            disk1
   Device / Media Name:      Hitachi HTS545050B9SA02 Media

   Volume Name:              Not applicable (no file system)

   Mounted:                  Not applicable (no file system)

   File System:              None

   Content (IOContent):      GUID_partition_scheme
   OS Can Be Installed:      No
   Media Type:               Generic
   Protocol:                 SATA
   SMART Status:             Verified

   Total Size:               500.1 GB (500107862016 Bytes) (exactly 976773168 512-Byte-Units)
   Volume Free Space:        Not applicable (no file system)
   Device Block Size:        512 Bytes

   Read-Only Media:          No
   Read-Only Volume:         Not applicable (no file system)
   Ejectable:                No

   Whole:                    Yes
   Internal:                 Yes
   Solid State:              No
   OS 9 Drivers:             No
   Low Level Format:         Not supported

Please let me know, if anything else could be of help.

1 Answer 1

-1

Had the same question... Fusion Drive utilizes a component of OS X called CoreStorage to work. When you boot your Mac holding down Option, you are booting into a screen running in the low-level EFI environment, before OS X has started. EFI doesn't understand what a home-built Fusion Drive is, but sees two physical drives capable of booting into OS X.

I'm not sure of the mechanics of why factory-built Fusion Drives in the latest Macs act differently but my guess is that there is a firmware chip of some sort, like you said. Apple is known to put custom firmware on some of their hard drives. (Answer taken from another post)

1
  • Hi Roman, Welcome to Ask Different, Please share the link of the original post, and elaborate the answer a bit more, adding details.
    – killswitch
    Oct 23, 2016 at 7:46

You must log in to answer this question.