0

I have tried multiple things to rememdy this issue. I have tried enabling and logging in as root, tried to clone the system preferences app and accessing security and privacy from the view menu and nothing seems to work. I have repaired permissions from disk utility, repaired permissions through terminal at utility repair and still nothing. I will say that there was a previous user at my machine which I went through the best approach I could find by saving the previous home folder and creating another. My new user is set to administrator also. I am open to any suggestions here as I am fresh out of ideas.

I also made sure to authenticate via the lock icon in system preferences pane.

Im running:
-3.4ghz i7 imac
-16g ram
-osx mavericks 10.9.5
-local network

Update:
just tried running this in terminal and restarting… also to no avail
sudo rm /Library/Preferences/com.apple.alf.plist

Update:
tried toggling socketfilterfw off and then on through terminal but both times terminal output that the firewall was already in the state I was attempting to set it to.
still no solution…

Update:
Im now gearing to wipe and reinstall my os drive. I have run out of things to try and assume that it's a convoluted permissions issue. If anyone has any last-ditch ideas, I'm all ears. Thanks for everyone's help.

Final Update:
I wiped and reinstalled… never got a solution to this one.

  • You must have a 3d party app controlling it. – Ruskes Oct 3 '14 at 16:14
  • Something like Anti Virus app, or dreaded Clean my Mac..ect. – Ruskes Oct 3 '14 at 16:19
  • Is there any way to isolate an offender? Ive looked through my app directory and nothing appears to fit that description. Im not opposed to command line solutions here either. – visyoual Oct 3 '14 at 16:30
  • Could you improve your OQ please? Could you write if you had this problem since the initial install, since a particular upgrade or since any other event. There are bugs, but they usually don't fall out of the blue sky :). – dan Oct 8 '14 at 10:28
  • I'm not entirely sure when the issue occurred as with most people I would assume, the firewall panel isn't a frequent access item for me. I did attempt to be as thorough as possible with the problem description, known variables and solution attempts. It is a machine I inherited at a job so I don't have it's complete history. So, I suppose what im saying here is if there is a common method to glean that information, I'm more than willing to find it, but at present this is all the information I have unless there is something specific that would help. – visyoual Oct 8 '14 at 13:16
2

My first assumption is that you have a app like Anti Virus that took over the control of your Firewall.

Here is a article on using the Terminal commands with Firewall.

It is for Lion, but I assume they still work with Mavericks.

For example to start it:

/usr/libexec/ApplicationFirewall/socketfilterfw --setglobalstate on

Give it a try.

  • terminal returned: Firewall is enabled. (State = 1) still no change for the preference pane – visyoual Oct 3 '14 at 19:43
  • Then turn of off and on again in Terminal to overcome who ever is using it. – Ruskes Oct 3 '14 at 19:56
  • --setglobalstate off terminal returns: Firewall is already disabled When I set it back to on, it outputs the same: Firewall is enabled. (State = 1) – visyoual Oct 3 '14 at 20:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .