6

I need to work with at least OpenGL 3.1, and i am not sure which version do i have.

When i execute this command on terminal:

glxinfo | grep "OpenGL version"

i get this message:

OpenGL version string: 2.1 NVIDIA-8.24.16 310.90.9.05f01

However when i check the version on program called "OpenGL Extensions Viewer" it says up to 3.3 but only with core features, what that means?

What if i install Windows and update the graphics drivers, i will still be able to use OpenGL 2.2 or more?

I appreciate any help.

Macbook 15-inch, Mid 2010 with NVIDIA GeForce GT 330M 256 MB, OS X 10.9.5

1

Your MacBook Pro has GPU support for OpenGL 3.3 when running Mavericks. That is according to this Apple article:

http://support.apple.com/kb/HT5942?viewlocale=en_US&locale=en_US

Installing Windows graphics drivers in OS X is not supported. Attempting to do so may render OS X unusable and is ill-advised.

7
  • Is there a way to make sure that my GPU supports OpenGL 3.3? Because i am not sure that article is right.
    – soltex
    Oct 3 '14 at 8:42
  • You could always install an OpenGL app that requires 3.3 and test. I don't know why you think an Apple kb article would be incorrect. Oct 3 '14 at 9:18
  • 1
    Because i am trying to run anything above 2.1 on Xcode and nothing seems to be working. I don't know if my libraries configurations are wrong, or my GPU can't support more than 2.1. I get an error related with the architecture on Xcode.
    – soltex
    Oct 3 '14 at 15:17
  • The problem that you seem to be running into is that XQuartz itself - the implementation of X Window System on OS X - only seems to support OpenGL v2.1. So, while the hardware can do a lot better, the X Server you're using cannot. See the following: stackoverflow.com/questions/15979491/… Oct 4 '14 at 4:56
  • P.S. - X on my Lion 10.7.5 system also exposes OpenGL 2.1 with direct rendering. Oct 4 '14 at 4:58
1

OpenGL 2.1 is Apple's legacy context. You need to request a core context for the system you intend to use, though, as you've discovered, XQuartz will only do legacy.

If you install Windows via Bootcamp & install the latest NVidia drivers for Windows, you will see the highest context your card can support, possibly 3.3 but may even be 4.2 [I don't have a Mac with NVidia to test, but my ATI HD 5770 can achieve 4.2 under Windows.]

This may be of assistance, even though it isn't marked as Answered - OpenGL 4.1(?) under Mavericks

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .