2

I have a black iPod Classic 160GB. I use iTunes on Windows 7 to sync songs. I can see the songs that are synced with the iPod, iniTunes. However, after ejecting, the iPod shows 0 songs. Going to settings show the decreased free space. Opening up My Computer, and I can see the songs in the ipod_control\Music folder. I have also set the songs to not be a part of a compilation, as suggested in this question. However, I have been unsuccessful in getting the iPod to show the songs. I am tired after fiddling with it since 2 days now. What gives?

  • Are you adding songs manually or automatically? (i.e. what is the setting set to in iTunes?) – CajunLuke May 25 '11 at 20:52
1

First, remove all songs from the device (from within iTunes) and then try re-adding them. If that fails to have any effect, remove all songs, unplug the iPod, re-plug, and add a few back. (Don't bother checking for songs in Explorer; that's not going to help.)

If that doesn't work, back up any data that has made it to your iPod and restore the firmware in iTunes. Then try to add a single song and see if that works. (Add a playlist with one song, then try dragging one over manually, if you prefer that setting.)

Comment on what worked or didn't: if nothing works, I'll come up with more things to try.

  • I tried manual and auto sync at first, still did not work. Then I did a restore, and synced songs, manually, and afterwards, automatically. I can see the songs in the iPod now. Restoring the iPod from iTunes did the trick. – theTuxRacer May 26 '11 at 2:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .