0

My Mac is OS X 10.4.11 with Bash version 2.05b.0(1)-Release (PowerPC-Apple-Darwin8.0) on a PowerMac. It is vulnerable and need to be patched. This Mac uses Filemaker 8.5 pro client and hosts the remote files sitting on the Windows server. It also communicates with the MYSQL DB which is again hosted on the Windows server

What is the possibility of my Mac being affected by this bug?

I do not see any patches for this version of bash.

I am not good in handling Mac OS compilation and installing. We are due to upgrade our Macs soon (early next year).

What might I do for now?

1

http://tenfourfox.blogspot.com/2014/09/bashing-bash-one-more-time-updated.html

If you go to this site, there's a precompiled binary that works for 10.4 (PowerPC). I'm using it and it works well.

  • Downloading binaries from random sites is an excellent way to have your system get owned. Just sayin'. If the user has the skills to compile his own binaries from official Apple or GNU source, that is absolutely the way to go. – Trane Francks Sep 30 '14 at 22:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .