6

I had tried to download the SE iPad app after upgrading from iOS 7 to 8. However, nothing happens when I click the download link. For those unfamiliar with the SE app, it's still in beta, so it has to be downloaded via web. It is accessed via an itms-services:// URL. (It's a bit of a secret exactly what it is.)

It worked just fine before the update. I never had 8.0 or 8.0.1.

Is there any known info on not being able to download apps from the web?

My bug report on Meta.SE is here: Unable to update app on iOS 8.0.2

7

This appears to be a bug with enterprise distribution in iOS 8. If you updated to iOS 8 and had an app with the same bundle identifier installed (i.e. the same app) then you'll be unable to install the app.

A workaround is to change the bundle identifier in the distribution plist. This doesn't require the actual bundle identifier of the app to change, just the distribution plist. Alternatively, you can wait until Apple fixes it.

SE have used the workaround to fix the iOS app beta distribution, as discussed in chat and on the aforementioned meta question.

  • 1
    How could I change the bundle identifier? Or, is there a timeline on Apple fixing it? (I personally don't want to wait 6-8 weeks. :P) – Scimonster Sep 30 '14 at 14:07
  • @Scimonster Either SE can change their plist, or you can download it, change it and upload it to your own https server. As with everything Apple, no timeline I'm afraid! – grg Sep 30 '14 at 14:11
  • The stack exchange developers have in fact changed the bundle identifier. – bmike Oct 1 '14 at 18:16
  • well appending .ios8fix to the bundle identifier in distribution plist file will make it able to download when you hit install button. but another problem is arising 1) another icon is shown as downloading which then merge to the existing app if your aer updating the app.(weird) 2)I deleted my app and downloaded fresh from enterpise link and it downloaded a very old version of that app(i know because its name was changed and it was known to me) which always crash on startup. after like 5 min or when you redownload it . orignal running app is with you. plz help how to debug this. – user101892 Nov 22 '14 at 14:49
  • @abhijeet If you have a new question, please ask it by clicking the Ask Question button. Include a link to this question if it helps provide context. However, be warned that software development questions are off-topic here, but can be asked on Stack Overflow. – grg Nov 22 '14 at 15:49

You must log in to answer this question.

protected by Community Dec 7 '14 at 15:11

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .