2

I'm using rsync to mirror files from my internal drive to an external USB hard drive. This is the command I'm using:

/usr/local/bin/rsync --archive --exclude='.DS_Store' --delete-after --progress --stats /Files/ /Volumes/BACKUP2014B

So files not on the main HDD will be deleted from the backup disk. This means that the files telling Spotlight to ignore the external disk will be deleted at every sync. Is there some way to avoid that? I don't like the fact that Spotlight reindexes my drive every day, it's a lot of disk crunching.

0

1 Answer 1

2

Things to try...

  1. Set the .metadata_never_index file to stationery or locked

  2. Put the entire backup structure inside a folder called myBackup.noindex

  3. Add it to the Privacy pane in Spotlight settings. [I don't know where that data is stored - if it's on the boot drive, then it will work, if it's on the relevant external drive, back to 1 & 2]

1
  • Option 1 worked: rsync: delete_file: unlink(.metadata_never_index) failed: Operation not permitted (1)
    – jimmy
    Commented Sep 30, 2014 at 8:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .