This question already has an answer here:

I already run the following and I get "vulnerable" Mac cysunza$ env x='() { :;}; echo vulnerable' bash -c 'echo hello' vulnerable hello

I read the post about it but appears to me that his is just for newer systems that mine, so my questions are: I should be worried about it? (my guess is yes) Is there a way to solve this problem, without a new system? if there are such a patch, where I can get it?

I upgrade my Mac to the last OS in another hard disk but I felt so slow, that's the reason I prefer work in the system 10.6.8 Thanks

marked as duplicate by bmike Sep 30 '14 at 3:16

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Apple has quietly dropped support for Snow Leopard and earlier versions. This page has various means of helping you to compile your own version should you wish to do so:

How do I recompile Bash to avoid Shellshock (the remote exploit CVE-2014-6271 and CVE-2014-7169)?

There is a lot of attention on all the posts on that page. Read it all and find the solution that feels the most comfortable for you. Asking there is probably going to get you more eyeballs than asking here.

Not the answer you're looking for? Browse other questions tagged or ask your own question.