3

so I tried to upgrade my Xcode to 6.0.1 from 5.6 or something. I'm running on Mac OS X Mavericks 10.9.5 yet.

The problem is that it starts downloading Xcode form the Mac AppStore and already replaced my old Xcode. So in the dock it is shown like a normal icon and when I click on it it says

"Xcode is being updated. Xcode can not be launched while updating"

When I open the AppStore it restarts the update and so on. So what I did was to download Xcode from the Developer's Resources site. Then I opened the .dmg and it gave me the image like opening a CD (I don't know how to call it, sorry). Then I copy the program to the desktop and it starts copying (preparing to copy) and nothing happens...

Then I tried to open it directly from the opened .dmg but just literally nothing happens...

Also I tried to deinstall "Xcode 6" with CleanMyMac2 but it starts deinstalling and says it finished right a second after.

Sorry for the long text but I thought an exact description might help you. Thanks for taking your time reading this, i'd appreciate an answer if you have one ;)

  • There are certain applications that cannot be run from a mounted .dmg – user125712 May 5 '15 at 18:18
1

Try deleting the Xcode.app from your /Applications folder and replacing it with the Xcode.app from inside the dmg that you downloaded. Once you have replaced the Xcode application try to open it and it should work. You usually can't run packages or applications from inside of a mounted dmg. It is recommended to copy what you need from the dmg and then running it.

  • First thanks for helping. I will check your way later but the last point you said is not correct. you can definitely run an application from a mounted .dmg Also, can you give me an up-vote please? I would like to up-vote your answer but do not have enough rep. – LinusGeffarth Sep 30 '14 at 21:15
  • Yes. I'm sorry for the confusion. – Andy Batey Sep 30 '14 at 21:36
  • @LiGe don't ask for votes etc. You should see if the answer is correct anyway before voting and you can accept the answer if it is correct which will give rep to the answer. All covered in the GAQ – Mark Sep 30 '14 at 21:39
  • @Mark I wanted to thank him for taking time and reading the whole long question with an up-vote even if the answer does not work. – LinusGeffarth Sep 30 '14 at 21:44
  • @AndyBatey So I dont know if it was because of your suggestion but it now copies. so anyway: thanks! – LinusGeffarth Oct 2 '14 at 4:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .