0

We have an iPad that is running iOS 8 and can't see that iOS 8.0.2 is available. This id true from both the settings app and through iTunes. Other iOS 7 and 8 devices on the same network can see the update and have been able to update. We've done a complete "Settings -> General -> Reset -> Erase All Content and Settings" but the reset OS also can't see the update. A restore from iTunes didn't seem to fix the issue either.

We also tried to update the OS from iTunes and are being told that the iPad is up to date.

This device at one point was managed by MobileIron, in case that makes any difference (we suspect it might). From our MobileIron interface, the device is no longer managed and the MobileIron app has been removed from the device.

1

The way to complete this is to locate a downloadable version of the iOS 8 install file. Redmond Pie has a great blog post with links to each version of the software.

http://www.redmondpie.com/ios-8-beta-download-release-date-features-rumors-and-news-update/

Once you download the version of 8.0 for your iPad version - following this:

Connect ipad to computer Click on iPad - Summary Hold and click on restore. A file dialog window should open, allowing you to manually select the restore media. Navigate to where you downloaded the iOS software to, and select that .ipsw file from the list.

It should overwrite and install the 8.0 version to the iPad.

Regards,

Ed

  • We will try this but what's the explanation of why it can't be upgraded? We did a restore so shouldn't it no longer be affected by the MDM (assuming that's the issue)? – Chris Williams Sep 30 '14 at 0:07
  • I don't know if I could provide a good explanation. I assume there are some software pieces that are not cleared in a restore, including potential enterprise hooks. You can also try putting the device into DFU mode. This forces iTunes to download the latest edition directly for update. imore.com/tip-put-iphone-ipad-dfu-mode – Edweird Oct 1 '14 at 8:03
  • It sounds like this wasn't related to the fact that the device wasn't managed - it could've been a problem finding Apple's authentication server. Regardless, downloading the IPA and installing it manually worked. – Chris Williams Oct 2 '14 at 15:06
0

Strange problem. Is date and time correct on your device? Know that Mobileiron can't prevent a User from upgrading the Operations system on iOS.

What Ed suggested should always work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .