I am using the 10.9.5 version and ios 8. When i try to install my certificate i got through my developer account for push notification for my app in the keychain local items, its not importing. The error says: Unable to import the certificate and the error code is 25294


Try adding the certificate to the "login" keychain.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • Please do not delete this answer, as it answers the question and I could not find this solution elsewhere – user174099 May 7 '17 at 18:28

The error code means "No such keychain":

errSecNoSuchKeychain -25294 The specified keychain could not be found.

I'm not really sure on how to proceed, but maybe this information points you in the right direction.


I worked around this error by adding the certificate to the login keychain by drag and drop.


I'm really not sure about what you're question is asking, but I stumbled here while trying to solve the same error. The situation I had on my machine was I had a bunch of similarly named keychains in keychain access and the application would default to adding the .pem to a nonexistent keychain.

So I solved this by selecting the missing keychains one by one and deleting them all except my real System keychain, iCloud, and login. You might not have iCloud depending on your setup, version, and location.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .