4

As the title says, whenever I repeat the ⌘ key it triggers a copy command (just as if I pressed ⌘C). I can even see the "Edit" menu entry blinking when I do that. This happens system-wide.

I checked OS X's shortcuts under System Preferences > Keyboard > Shortcuts, but there's nothing there. I also checked other apps, like BetterTouchTool, but it's not defined in any of them.

This started happening a couple of months ago and I'm going a bit crazy with this. Is there any way I can know which app is creating / assigning each shortcut? That could massively help narrowing it down.

Thank you!

  • 1
    Keyboard shortcuts are often set per user account. Do other user accounts have similar issues? Have you tried to restore the keyboard shortcuts to their default settings? (System preferences -> Keyboard -> Shortcuts 'Restore Defaults') – CousinCocaine Sep 27 '14 at 17:38
  • 1
    There is only one user account, mine. I've tried setting the shortcuts to their default settings, yes, but to no avail. I think a 3rd-party app is causing this, although I can't for the life of me figure out which one. – goncalossilva Sep 29 '14 at 11:17
  • 2
    You can create a new user... This might help debugging this problem. – CousinCocaine Sep 29 '14 at 12:56
  • do you have a program or extension that modifies your clipboard in some way? perhaps that program has an internal means of setting a keyboard shortcut. – TheWellington Oct 30 '14 at 21:08
1

You may get some luck if you download and install CheatSheet - it builds a list of shortcuts for the current application, so you may be able to track it down by working through your apps with that.

  • I think this is a good suggestion to anyone hitting the same problem, so I accepted it. Eventually I did a clean install for Yosemite and the problem went away though :) – goncalossilva Dec 2 '14 at 15:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .