5

I updated from iOS 8.0 to iOS 8.0.2 on my iPhone 6 last night and noticed after the update completed that the Settings app shows a badge on my home screen even though there is no apparent update available in the app (including an iOS software update - which shows iOS 8.0.2 is installed and is the latest version).

I saw a comment elsewhere (ios 8.0.1 - download completed but unable to install) implying this was seen with iOS 8.0.1 also and wondered if there is a way to reset the settings app badge or if this may be a bug that remains in iOS 8.0.2.

UPDATE: As an additional data point the count on the settings badge inexplicably went from 1 to 5 today. I have not done a DFU restore, and may eventually resort to that, but for now would rather not go through that process and am hopeful a different fix is possible.

  • My settings app badge is stuck at 1 after update from 12.0.0 to 12.0.1. Restarting did not help. – Daniel Oct 13 '18 at 18:23
0

I found a MacRumors thread complaining about the same thing, and more Google results about the same problem happening as far back as iOS 6. It can apparently be fixed by a DFU restore, if you're willing to be that drastic. Otherwise...wait for the next update.

  • Thanks - I suspect your right that a DFU restore would work. Not ready to do that quite yet, but would be glad to hear if anyone else tries it and it fixes the issue on iOS 8.0.2. – natonic Sep 26 '14 at 20:34
0

Have you tried reboot device? Turning off and on sometimes helps, also you can try restart only Settings.app in multitasking menu (double tap home button), find Settings and swype up or down

  • Tried both of those, also tried killing all running apps from the multitask menu and then doing a hard reboot (home and power button held for 10 seconds). No change. – natonic Sep 26 '14 at 20:31
0

A Device Factory Update (DFU) restore will repair this issue, but ensure you back up all important data before attempting to restore your device.

0

You could also ignore it until the service that provides that update catches up and resets itself.

I've seen several cases where a stuck badge in an off-by-one state just clears itself within 48 hours. Hiding that app in a folder and using siri/spotlight to launch it could help if you just can't stand the sight of the red circle.

You certainly don't need a DFU restore to clear that, a plain old restore or even erase all contents and settings (make sure your iCloud drive is backed up to a computer before doing so) would clear that update notification in all likelihood.

0

This problem was resolved when I upgraded to iOS 8.1.2 (it was not fixed by 8.1.1 by the way).

You must log in to answer this question.

protected by Community Sep 28 '14 at 11:38

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .