0

I am using Xcode 5.1.1 as I require an app which supports iOS 6.1 and Above with base SDK iOS 7.1. I tried upgrading Xcode 6.0 but it is not able to run iOS 6.1 simulators. So I reverted back to Xcode 5.1.1 with a backup that i had kept. As I upgraded my device to iOS 8.0, I am not able to run the same on the device with Xcode 5.1.1.

The following is the screen shot of what I See in the organiser.

enter image description here

Is there any way to run my app on iOS 8.0 Device using Xcode 5.1.1?

  • 1
    What makes you think iOS8 can run on a older version of XCode ? – Jash Jacob Sep 26 '14 at 16:51
3

You need to gather symbols from device before connecting it to Xcode 5. Download and install Xcode 6 side by side with older Xcode. Connect iOS8 device to Xcode 6. Wait for it to collect symbols and see if device is ready for development. From now on Xcode 5 is able to "see" the device properly.

0

AppCode connected to xCode 5.1.1 is capable of running apps on iOS 8.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .