3

I felt like giving my mess of Launchpad icons a fresh start. So I did

defaults write com.apple.dock ResetLaunchPad -bool true && killall Dock

On checking Launchpad, it had appeared to have reset itself to default layout. Then to stop it resetting again on every reboot, I did

com.apple.dock ResetLaunchPad -bool false

It's always worked in the past but now I've discovered that no applications in /Applications/Utilities appear in Launchpad anymore. Terminal, Activity Monitor, AppleScript Editor and all the rest are missing:

Where's Terminal! Ahhh!!

The ones you see here actually reside in just /Applications. But Utilities are supposed to populate here amongst them.

The problem is persisting across users and also when I create new users. I find that very odd in and of itself because I did not use sudo or otherwise elevate the commands I used to set the ResetLaunchpad flag.

Basically, I don't want to have to drag the apps in /Applications/Utilities to the Launchpad icon and then manually organise them back into Launchpad's "Other" folder every time I create a new user.

Any ideas how I might be able to get Launchpad to behave normally again? Thanks! I'm using OS X 10.9.5.

  • Did you ever figure this out? I'm running into the same problem. – Chris White Jan 12 '15 at 18:28
1

I don't know if this is a related cause and the potential fix but I was able to get the issue resolved for me.

I use Homebrew Cask and I have it setup to symlink the applications from my Homebrew Cask directory into my /Applications/ folder (the default is ~/Applications).

The solution for me was to remove all of the Symlinks (I just moved them to my desktop) and then I ran the terminal command:

defaults write com.apple.dock ResetLaunchPad -bool true; killall Dock

After doing this my Utilities folder showed back up and when I moved the symlinks back into my Applications folder everything was back to normal.

If you do have symlinks in your /Applications/ directory or maybe even aliases it's probably worth giving this process a try.

Hope that helps.

  • I tested it for myself. As you say Utilities stop showing in LP when symlinks to apps exist - not only in /Applications/Utilities but in /Applications as well. After moving them to the desktop, running the command again fixed it. This one was truly beyond me. Thank you. – iceequal Jan 29 '15 at 1:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .