I'm using Microsoft Remote Desktop 8.0.9 from the app store and connecting to Windows 7 and Windows Server 2003 based PCs.

Although alphanumeric keys work properly, when I type certain symbol keys into the remote computer they come out as the wrong keys, it seems like a mapping issue. The remote machines are both set as "English (United States) - US" for the input language, which matches what my Mac has.

The following is example of the key confusion:

\ maps to <
< maps to .
^ maps to ?
{ (twice) maps to ^^ (but once does nothing)
} (twice) maps to -- (but once does nothing)

Most other keys work fine. What can I do to correct this keyboard mapping on either the host (OSX Mavericks) or the client (Windows 7)?

  • I am also having the same problem. We are a hair salon and use Microsoft Remote Access to run our salon software called Insight. Whenever I try to use the "@" symbol it creates a " instead. Whenever I switch back to my normal apple computer the symbols return and the keyboard mapping is fixed. Help!
    – user92473
    Sep 26, 2014 at 20:07

5 Answers 5


I had the same problem using microsoft remote desktop on a mac with OSX Yosemite. My symbol keys did not work correctly, for example the \ became < and @ became *. I opened system preferences on my Mac that was running the RD client, and under keyboard I noticed that my input source was set to Canadian English. I added US English, deleted Canadian English, and restarted the remote desktop session. The special characters were typed correctly after that.

  • 1
    I made the change to US Keyboard on the remote Windows computer I was using (the bottom right in the Windows taskbar) and it worked. To clarify, for me, I didn't have to change settings on my Mac. Mar 12, 2015 at 17:23

Found an answer in an App Store review of all places, but to get your @ and " where you expect them to be, go to Remote Desktop / Connections / Keyboard and change Scanmode to Unicode.


I also had this issue but for me it only started with recent Microsoft RDP for OSX updates. The switch between keyboard layouts was happening whenever I used the Left Alt + Shift key combination which was quite common (and very annoying) while using Visual Studio.

On the Windows machines I was RDPing to I went to Region and Language > Keyboards and Languages > Change keyboards..., then on the General tab of Test Services and Input Languages I removed all the unused items from the Installed Services list and clicked Apply. On the Advanced Key Settings tab ensure that only your selected service is displayed. You can also change the Left Alt + Shift key combination on this tab.

  • Thanks a thousand times! That's exactly what I needed to get my new logitech keyboard to work correctly with my RDP PC. It's been 3 days and I was going nuts. This answer should have more upvotes, as it's still valid after 6 years.
    – Olivier H
    Feb 28, 2022 at 8:36

This question is super old now, however this might help someone with a similar issue. Mine specifically was with the backtick/tilda (`/~) key, above the 'tab' key. I was RDP'ing from OSX Catalina 10.15.5 into a Windows 10 machine. The windows machine was running a Ubuntu 14.04 VM in Virtual Box and the tilda key was producing different results in windows (|) vs Ubuntu (<). Note: i'm using an external Microsoft keyboard (for ergonomics) connected to my Mac. It works as expected for my Mac. I searched all through the Windows 10 settings on the remote machine for what I could change as far as keyboards go, but nothing worked.

My Solution: What did fix it was upgrading from the Microsoft 8.x client to the 10.x client on my Mac... figures.


Charset config for remote connections..

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .