2

I am not used to using OS X as I normally use Windows but in my new job I have a machine with OS X 10.9.5 so I kind of have to use it.

Anyways, I need to open port 25443 as I need it to access a website that runs there. I am not using the OS Firewall. I've been reading about it and I tried ipfw but it seems to be deprecated. I've been looking into pfctl but no luck. How could I open that port?

These are the outputted messages in different browsers:

  • Safari:

    Error shown in Safari

  • Chrome:

    Error shown in Chrome

  • Opera:

    Error shown in Opera

The website is on a server in the Internet, is not accessed locally

I've tried to access other websites using HTTPS. It doesn't show any error and it show without any problem.

  • Your question is a bit vague. You are running this webpage locally? Then you should be able to access it at 127.0.0.1:25443. Otherwise; outgoing connections are not blocked by the standard firewall, so there is no reason on the OS side why you wouldn't be able to access the server. – Volsk Sep 24 '14 at 8:59
  • The website is located in a server in the Internet so I am accessing it as any other website. I've been trying with different browsers(Safari, Opera, Chrome and Firefox) and I get the same output in all of them: couldn't access the web because of a SSL error. I've tried to access it in my Windows 7 laptop and I can access it without problems, but with the Macbook of my work colleague the same problem occurs. That's why I think the port is closed... – Domeinuak Sep 24 '14 at 9:06
  • 3
    @Domeinuak if the port were closed, you wouldn't get an ssl error. It sounds like your pc was configured to not warn you of insecure ssl certificates. You need to figure out how to accept the certificate or bypass the warning. Can you post screenshots? Press command shift 3 and the screenshot will save to your desktop. – Harv Sep 24 '14 at 9:20
  • @Harv I've added the screen shots to the original message – Domeinuak Sep 24 '14 at 9:32
  • I too can access the url just fine on 10.6.8 Have you tried from a different user account, just in case something is messed up with yours? – Vic Sep 24 '14 at 12:43
1

Router/Firewall settings

As your site loads fine for other SE users, even with OS X firewall activated, it is most likely that you are behind some sort of company firewall.

Try another network, like tethering from your phone, to see if this solves your issue.

| improve this answer | |
1

Not an answer, but I do not have any issue from my MacBook. I also don't see anything wrong with the certificate. Can you access other https sites?

enter image description here

| improve this answer | |
  • I've tried other sites (Gmail and my banking system, for example) just to double check and I can enter without any problem... – Domeinuak Sep 24 '14 at 12:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .