0

My MacBook Pro (2011), with OS X Mavericks, can connect to WiFi in some U.S. homes perfectly fine, but not other homes in the U.S. The "bad home" with WiFi where it fails to connect has other computers (not Macs) that can easily connect to its WiFi.

I have tried restarting the WiFi router in the "bad home" but it doesn't fix the problem. I have also tried using the WiFi Diagnostic Tool (starting with the exclamation mark) twice, but it couldn't solve the problem either.

What could be wrong?

  • I assume the owner of the WiFi has given you SSID, password and encryption type. Do they use MAC filtering? – Milliways Sep 23 '14 at 3:28
  • @Milliways, what should I do differently if there is MAC filtering? Does the Mac not detect MAC filtering? – Alice Sep 24 '14 at 2:57
  • MAC filtering is a setting within the router. Clients have no control over it. It is basically a blacklist/whitelist of who can access and who cannot. In this case it is possible that it could be a whitelist where only specified MAC addresses are allowed to connect to the network. If your MAC address is not in the list within the routers control panel, you will not be allowed to connect. Try talking to the owner of the WiFi to see if this is the case. Clients have no control over MAC filtering. – SteppingHat Sep 24 '14 at 3:08
  • This could be so many things... The DNS servers could be hardcoded (saved on your mac). These DNS servers might be specific to some ISPs only and therefore not work at different locations. Remove any DNS servers in your WiFi's advanced settings that are set. There was a time when Macs had trouble connecting to WEP Wireless routers. I don't know if this is still a thing (I wouldn't think so) – cloneman Sep 24 '14 at 4:00
1

Perhaps the "bad home" wifi is using channels 12 or 13?

The answers to this question might help diagnose if this is the issue.

  • Both the home that WiFi connects and the home that the WiFi fails are in the U.S. – Alice Sep 24 '14 at 2:59
0

I jut had this happen to me on my 2013 MacBook Pro. It would connect at home, but not at work or at Starbucks. After some investigation I discovered I had somehow assigned it a static IP in my Network Preferences (although I have no recollection of doing that LOL). To see if that is the issue Open Network Preferences, click Advanced, click the TCP/IP tab, and ensure the Configure IPv4 dropdown is set to Using DHCP, and click OK. I suppose, you may have to click Renew DHCP Lease, but I didn't have to. It connected as soon as I changed it back to Using DHCP.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .