5

I have successfully routed my system audio through AU Lab via Soundflower, but it clicks.

To my knowledge, that clicking sound usually means that buffer sizes are out of wack (either too small, or not consistent across any applications in the signal chain).

Yet, trying to match the settings as follows doesn't seem to fix the problem.

My settings:

• In Soundflowerbed, buffer size = 2048
• In Info pane for AU Lab (CMD+i), selected 'Open in 32-bit mode'
• In AU Lab preferences, buffer size of all devices = 2048
• In System Prefs > Audio Midi Setup, Format of Built-in Output = 44.1k, 32 bits, to match Soundflower.

A few observations:

• In AU Lab, regardless of what settings I've selected in Preferences, it shows the Frames settings of Built-in Output to be 512, which is not necessarily what I have it set to. That figure gets updated for Soundflower. Not sure what that's about.

• Setting all buffer sizes to 512 to match the above does not fix the problem either.

• Clicking is present with all audio, consistently, and begins as soon as audio starts. If there is no audio, there is no clicking.

• In Audio Midi Setup, Soundflower says its audio is of the 32-bit integer variety, while the closest option Built-in Output has is 32-bit float. I don't know enough about digital signal processing to know if that's an issue.

I am on the Mid-2014 model MBP with OSX 9.4, Soundflower 1.6.6, and AU Lab 2.3.

  • is it constant or rhythmic, does it reacts to volume control or remains constant ? – Ruskes Sep 23 '14 at 0:11
  • @Buscar웃 It is only ever as loud as the audio (so if I turn my audio off at any point, either the source, or anywhere along the chain, I hear no clicks), and I haven't noticed any rhythmic patterns. – Aidan Miles Sep 23 '14 at 0:20
  • OK, try resetting your SMC to see if that was it. – Ruskes Sep 23 '14 at 0:48
  • I don't believe that the SMC is the issue. I'm experiencing zero other performance issues, even when pushing the computer pretty hard. Also correct me if I'm wrong, but the SMC isn't responsible for things related to system audio. If I don't patch my audio through AU Lab, there's no clicking. That is a pretty clear sign to me that it's likely a software issue. – Aidan Miles Sep 23 '14 at 21:11
  • Same issue here although in Yosemite with AU Lab 2.3 and Soundflower 1.6.7. I run audio to an aggregate device consisting of the built-in output optical to a receiver and a USB audio DAC to a second subwoofer. Using just soundflower is clean but going through AU Lab gives me all kinds of crackling. I think this has something to do with Apple's core audio components. Is there anyway to downgrade them within Yosemite? – Mashuri Clark Oct 20 '14 at 21:01
4

Soundsiphon solved it for me as well. You do not need to buy the pro version, because the capturing of whole system audio (which means no specific application like safari needs to be selected as an audio source) is for free. :-)

My setup: soundsiphon as default system audio device: enter image description here

any Audio player/source on OS Yosemite -> AU Lab 2.2.2 (IN soundsiphon -> Waves GEQ -> OUT FiiO DAC: enter image description here

Sorry for the german screens :-)

  • Marking this as correct bc it solved the issue, and includes helpful pictures – Aidan Miles Dec 16 '14 at 17:36
  • I've got this working (haven't been running long enough to verify that clicking has been solved since my clicking only occurred after longer periods of play). Unfortunately now my volume control doesn't work unless I mess with the slider in the Sound preferences. Any fix for that? – Nick Jan 9 '15 at 3:03
1

I fixed the problem permanently. 0 clicks 100% of the time.

I have macbook air mid 2013, OSX Yosemite AU Lab 2.3.1 Sound syphon http://staticz.com/soundsiphon/

Sound siphon is a replacement program for soundflowerbed. It does the same job. i think its free? the demo is running now but it doesn't seem to tell me days remaining.

Im going to go spread the word now.

  • it is free on 10.8 but it costs $29.99 on 10.9 and above – Ruskes Nov 9 '14 at 5:43
0

It's exactly the same here, periodic clicking, about 3 times a second. Sound like dropouts. I don't think there's anything we can do :/ I've had the exact same setup working flawlessly in previous versions of OX, even Mavericks if I remember correctly. Apple broke it with 10.9.4. And when you look at the date of the public version, 2.2.2... it's from 2012. 2.3 is not public (beta?) and not working either. Obviously it's no priority for Apple.

On my system it doesn't click right away though, only after a while. There's a handful of temporary fixes that sometimes work for me:

  • Closing and reopening AU Lab and the application that is playing back the sound

  • In AU Lab, under "Window" -> "Show Studio", then change the input and output channels, "apply channel changes", revert to the right channels, apply again.

The latter fix used to work all the time, now it doesn't. It's all super random and frustrating. I really need it to work, cause I'm using an acoustics correction plugin. Now I'm fiddling with AU Lab 30 times a day.

One final observation: Certain applications are way more likely to start clicking. The most likely one is Safari content, Soundcloud in particular. Disabling Safari cache didn't help though (to be honest I have no idea why it should change anything, I just try everything).

System info: Mac Mini i5 2011, 16GB Ram, 512GB 840 Evo SSD, OSX 10.9.4, AU Lab 2.3, Soundflower v1.6.6, Motu 828 Mk1

0

User Carmine Paulino's fix on Github solved the issue. Found it via his answer on another question. His update also adds a few nice UI elements to the Soundflowerbed dropdown, shown below.

Screenshot of dropdown for Carmine Paulino's Soundflower update

It still clicks briefly when waking from sleep if there is audio playing, but that gets resolved without any work on my part. Great success!

0

Glad it's working for you! Soundflower 1.6.7 changes nothing on my system though.

I might have to force rebuilding kernel extensions though, I recently read that occasionally old extensions don't unload properly when you update them.

  • why not just uninstall and then reinstall? the uninstall script gets rid of all the files – Aidan Miles Sep 24 '14 at 19:01
  • 1
    also this isn't an answer; you might consider taking this and moving it into a comment. – Aidan Miles Sep 24 '14 at 19:02
  • Weird, I tried commenting and it wouldn't let me earlier. Sorry. – Rick Mavers Sep 25 '14 at 18:54
  • Anyway, yes of course I did uninstall and reinstall the later Soundflowerbed version. What I was referring to is that (from what I've read) sometimes cached version of kernel extensions still refuse to be replaced with newer ones. But I don't think it's that, in this case. – Rick Mavers Sep 25 '14 at 18:59
  • So currently it's like this: After about 5 minutes of listening (let's say Soundcloud in Safari) sound starts to get chopped up, rhythmically. BOTH AU Lab and Safari need to be restarted for the problem to go away, for a few minutes again. – Rick Mavers Sep 25 '14 at 19:01
0

I'm having exactly the problem described above - with Yosemite, all the latest versions of everything, 64 bit mode, 2048 frames, etc. I've tired every fix, messed with all the parameters, and still a persistent clicking noise and overloads from AU Lab - even when running no other applications AND no effects or plugins at all. Just running audio though SoundFlower -> AU Lab messes it up.

So, I guessing, something deeply wrong in CoreAudio. Very frustrating as I put a lot of time into RTA EQ profiles using AU Lab.

My work-around for the moment is to use Adobe Audition for EQ. Run audio through a dummy multi-track session, monitor a stereo track, and use an EQ Effect. Overkill, but it works well - and you can play adjust the wet/dry mix which is nice.

0

I turned down the output volume in system preferences, then increased the volume on my external amp.... this solved the issue for me. ^_^

You must log in to answer this question.

protected by Community Dec 2 '14 at 19:52

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .