4

Since the new IOS 8 I have had several problems with my iPad. One of which is the App Store is in Turkish I have checked my country and language everything is fine. Since its in Turkish it will not allow me to update any programs saying I need to switch to the U.S. Store, how do I do that? Several of my games no longer work after the upgrade.

1

All the way at the bottom right corner of the Apple Store screen there is a round symbol representing which country Apple store are you in.

country

Click on it and it will bring you choices to switch country.

1

Close the open apps on your device and go to 1) Settings 2) Itunes & App Store 3) select: Apple ID 4) choose: View Apple ID 5) provide your password. It should be working. Success!

0

Beside what @Buscar웃 suggests, I would recommend:

  1. Go to Settings > iTunes & App Store
  2. Logout your Apple ID
  3. Re-login Apple ID: If iOS detects the App Store language does not match your Apple ID's mapped Store location, it will launch App Store & switch to that language.

p.s. I always use this trick to switch between Japan & Hong Kong store.

0

I just had this issue. Here is what worked for me:

  1. Go to iOS settings.
  2. Select iTunes & App Store.
  3. Tap View Apple ID.
  4. Enter your password.
  5. iOS prompted that "your App Store is not the U.S. store. you will be redirected to the U.S. App Store right now." I tapped Okay and the U.S. App Store popped up :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .