7

I've recently upgraded my iPhone 5s to iOS 8, and installed SwiftKey. I really like it, and I'd like it to be the default, but my keyboard keeps switching back to the default. I can switch back to the SwiftKey keyboard with the "globe" icon, but this is annoying, especially since the two look similar.

Is there a way I can either make SwiftKey the default, or remove the standard Apple keyboard?

My Keyboard settings page looks like this (note that SwiftKey is already at the top, which is how I assumed the default was set, but the default doesn't seem to be sticking):

  • Check this article on iMore for setting custom keyboard as default one on iOS 8 http://www.imore.com/how-set-keyboard-your-default-ios-8 – I-M-JM Sep 22 '14 at 12:47
  • As explained in the question, I had already done this, and it wasn't working. – Andrew Ferrier Sep 22 '14 at 13:26
  • 2
    same for me. Even if I set Swiftkey top of the list I still get the regular keyboard by default. I deleted the regular keyboard and re-added so it naturally fell into second place. It still comes back as default so I will just have to delete it – user91649 Sep 22 '14 at 17:08
  • same here. the default keyboard doesn't seem to stick. TO make things worse, everytime after I restarted the phone, I have to toggle off/on the "give full permission" setting otherwise Swiftkey wont work. – ronaldwidha Sep 24 '14 at 15:38
3

Yes, you can swipe in the Keyboard Settings page to delete the default keyboard or tap edit in the top right and delete it that way.

  • I assume you are referring to the default keyboard, even though you don't say that. I have deleted it, and will see if this works. – Andrew Ferrier Sep 22 '14 at 13:25
  • This seems to have worked. – Andrew Ferrier Sep 29 '14 at 8:12
  • It's unfortunate that this is the only solution because the default keyboard is the only one that allows voice dictation. It's nice to have it around just for that... – Jim Greer Feb 6 '16 at 23:48
4

Settings>General>Keyboard>Keyboards sets the keyboards you wish to use. The top keyboard in the list is the Default. "Edit" will allow you to edit, remove keyboards or move a keyboard to the top of the list. To get Swiftkey as the default keyboard, move it to the top of the list. I tried it and it works for me, of course as per below there are instances when Swiftkey wont be the default keyboard.

However, there are instances where your default keyboard will NOT be used, no matter the settings. Examples include when security settings, passwords etc are required, the standard Apple keyboard (now referred to as 'Quicktype') will launch. So do not expect the 3rd party keyboard to function exactly as the built-in one does...there will be places where it refuses to launch, usually due to a security issue.

As of Sept 2014, this is a new feature, so it is likely that there are refinements that will happen over time to help make the use of 3rd party keyboards more seamless.

  • OK. In that case, there seems to be a bug here - the default simply doesn't stick for me. There are cases where the original keyboard comes up as the default, but I can still switch to SwiftKey (e.g. it happens periodically in Messages). – Andrew Ferrier Sep 22 '14 at 13:23
0

There was an update 8.0.2 that was supposed to resolve a bug the keyboard settings however after updating I was still not getting SwiftKey as my default keyboard, even though it was set at the top, what I did was change the order, then went into an app, pulled up something that needed the keyboard, got the default is keyboard, then went back into setting and made SwiftKey my default again and now it's sticking as the default keyboard

-2

Just move SwiftKey to the top of the list.

  • 2
    while your answer might be correct, it is one liner without references. – Ruskes Oct 7 '14 at 23:35
  • 1
    As I've already explained in the question, it's at the top of the keyboards list. Downvoted. – Andrew Ferrier Oct 8 '14 at 0:28

You must log in to answer this question.

protected by Community Oct 8 '14 at 14:16

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .